Docker install on windows 8: command not found

Hello all,

I’m new to docker and i install it on linux (Fedora 20) and windows 8 (64 bits). In Windows i follow the steps in https://docs.docker.com/windows/step_one/ and i did a custom install (full install without Virtual Box, since was already installed) and when i start “Docker Quickstart terminal”, i get MINGW32 window with docker ascii art logo and usefull messages but docker is not in the path, returning me a “command not found”. What is the best way to trobleshot this problem?

I have some dev tools already installed (Android Studio, Unity, Vistual Studio, git, putty)

                    ##         .
              ## ## ##        ==
           ## ## ## ## ##    ===
       /"""""""""""""""""\___/ ===
  ~~~ {~~ ~~~~ ~~~ ~~~~ ~~~ ~ /  ===- ~~~
       \______ o           __/
         \    \         __/
          \____\_______/

docker is configured to use the default machine with IP 192.168.99.100
For help getting started, check out the docs at https://docs.docker.com

Welcome to Git (version 1.9.5-preview20150319)

Run ‘git help git’ to display the help index.
Run 'git help ’ to display help for specific commands.

ppolonia@MAXTOR8DEVPT ~
$ docker
sh: docker: command not found

ppolonia@MAXTOR8DEVPT ~
$

Problem solved: I make the local path and the machine path the same, includind docker folter. The setup only change my local path.

Hi @polonia

Would you kindly elaborate on your fix as I am having the same issues? Did you modify paths in your system $path variables? Or in the start.sh?

Thanks in advance!

Hi,

I ran into the same problem and found out, that the PATH variable was set only for the Admin user, who installed the DockerTools. But I always run programs as a different user. So I appended the PATH at “system variables” (e.g. “foo;bar;…;C:\Program Files\Docker Toolbox”).

If you don’t know how to do it in windows see http://www.howtogeek.com/118594/how-to-edit-your-system-path-for-easy-command-line-access/.

HTH Danny

So I just recently had this same issue. Turns out I was using PATH as a variable in my shell script, which, if you’re paying attention, is a bad idea. My actual PATH was being overwritten with a random string, so I was getting the error docker: command not found.