Docker” is damaged and can’t be opened. You should move it to the Bin

Hello I am trying to download and install the Docker for MacBook pro - however every time the download completes and i try to install i receive the following error message, can anyone assist or provide a solution to this please?

" “Docker” is damaged and can’t be opened. You should move it to the Bin.

I’ve tried uninstalling, removing all previous docker files etc, then downloading and reinstalling everything nothing seems to work!

Put in the Applications folder and then install it using CLI
sudo /Volumes/Docker/

This won’t even work as the error happens during the second step of installation itself where

" 1. Double-click Docker.dmg to open the installer, then drag the Docker icon to the Applications folder. By default, Docker Desktop is installed at /Applications/"

In this step just before installation to finish the persistent error message props out


Here’s a screen recording link for reference

@evox95 recommended installing from command line. That wouldn’t have the double click step. There are two tabs in the linked documentation. Choose “Install from command line”, but I’m not sure why that would work better.

Make sure you download the the installer for the right architecture. In your video the filesize is 610MB. When I download it for the Apple chip, it is less then 500MB (4.28 or 4.27) and when I download it for the intell chip, it is still less then 600MB. Which one did you download?

Nope the file size is 488.3mb and the version is v4.28.0

Also, I’ve fixed this problem myself it was the MacOS which was not letting the setup to finish and in my observation, I found out that the checksum for the docker-engine in the setup was somehow not matching wich is why MacOS was blocking the whole installation steps of solving the problem for me was

  • Update the existing rosetta by running softwareupdate --install-rosetta
  • Running brew update and brew cleanup for updating used packages and removing unnecessary ones.
  • Also I’ve installed docker-engine using brew install docker
  • Install the docker-desktop by double click method.

These steps worked for me.

It wasn’t in the video

But thank you for sharing your solution

1 Like