Docker issue with port 80

Hi, docker is running with port 80 in the terminal, but when I try with http://localhost which is giving me nothing.
Docker version 20.10.21, build 20.10.21-0ubuntu1~22.04.3
But I can see other ports (9000) are running as expected in terminal & localhost.
What is wrong here ?

Uhmm, great question!

Though, there is nothing in the post that helps us to answer that question. You might want to add details about how you start your container (as in exact docker run command or the compose file content)

Nothing is usually something. An error message for example. When you share what @meyay asked for, please also share what error message your browser gives you because different error messages can mean different things.

I am running docker-compose up -d command …
it is running UI ( hygieia ), sonar and mongo.
If I try to access using localhost, sonar is running in port 9000 where as UI is not able to access…

sonarqube is running with 9000 port without any issue.

I am using docker-compose file of this repo

Note: I am not using jenkins here… removed jenkins details from docker-compose file.

Please add details about how you start your container, so that others are able to reproduce what you are doing. None of your posts so far helped to actually understand what you are doing and how you are doing it exactly It is not uncommon that problems are caused by details users decided would be irrelevant.

We are pulling the docker image of hygiea

docker-compose pull hygieia

starting the container

 docker-compose up -d 

process is running when I do docker ps -a…

Not sure…what went wrong here while accessing http://localhost showing me as “site can not be reached.”

Docker seems to be working perfectly.

SOCKET_NOT_CONNECTED is a DNS resolution error. Try using curl and/or instead of localhost. curl should always be your first tool when looking at web server problems.

In any case, this is a problem with your configuration of hygieia not with docker

hm… when I do curl
curl: (56) Recv failure: Connection reset by peer

Please re-read what I quoted in my last post, but read it completely :smiley:

Have you tried to check the Docker container logs?

The link to the compose file was actually shared before your quote, but I missed that first as well.

docker logs size is zero… not sure why …

Well, from my perspective pointing to a repository or tutorial isn’t really satisfying the need to see the actual compose file. We have seen it many times that problems were caused by the parts the users changed, but didn’t share…

agree @meyay your points… but in this case we downloaded as per git repo mentioned above…
atleast we suppose to get logs… here we are not getting any…
simple commands… but no output :grinning:

So to summarize,

  • we don’t know the software (at least I don’t)
  • There are no logs
  • the software is 3 years old
  • You removed jenkins from the compose file, however, it was a dependency of hygieia.
  • I guess you removed Jenkins because it didn’t work (it didn’t work for me when I ran it today)

I’m sorry but don’t see how we could help here. I think your best chance is trying to get help from the developers on GitHub.