Docker Community Forums

Share and learn in the Docker community.

Docker journald limitation


(Mskalick) #1

Hello,
I have a problem with logs from docker with journald logging backend. Logs from container contains only 999 lines of output. I can’t get more.
How can I setup it to get more lines? Whyt is this happening?

Thank you for your answers,
Marek


(Dvohra) #2

Set option

–log-opt max-size=50m

or more.


(Mskalick) #3

Thank you dvohra.

Isn’t this only for json-file driver? With journald I get:
“level=fatal msg=“Failed to set log opts: unknown log opt ‘max-size’ for journald log driver””

Is this somehow applicable for journald?


(Dvohra) #4

Use journalctl to get log messages.


(Mskalick) #5

Even with ‘journalctl CONTAINER_NAME=…’ I can’t get more that 999 lines :frowning: (I am listing all files from RPM, so it should be 54000…)

So it is not docker (and its journald logging driver) setting but journald one?