Docker Community Forums

Share and learn in the Docker community.

Docker keeps telling to switch to ZSH, but then doesn't do it

Hi all. Just installed and ran Docker for the first time on my Mac. I got a prompt in the terminal area saying:

The default interactive shell is now zsh.
To update your account to use zsh, please run chsh -s /bin/zsh.

So I did that, and got

chsh: no changes made

And the terminal continues to use bash. But zsh is the default shell on my system. Anybody know what the deal is here? Thanks!

Where exactly is that? Is that some terminal invoked from the Desktop GUI?

(Aside, with a 2 weeks old fresh install on Big Sur Intel, also using zsh, I do not see that message when using the “CLI” option for a running container in Desktop. And I do get zsh in the Terminal that is launched then. Just like when starting Terminal manually without Docker.)

Thanks for the reply. Upon launching the Docker app and waiting for it to finish launching, it presented a console pane on the right side of the UI. I think this was some kind of quick-start mode or tutorial offered on first launch. If I recall, there was a suggestion on some image to download. It wasn’t the Developer Tools console.

Now that I’m past this, the console isn’t presented anymore and I have no idea how to re-invoke it. ¯_(ツ)_/¯