Docker Login for Oracle Cloud Infrastructure is Unauthorized


I’m having an issue logging in on docker for OCI, this is my command:

docker login

For Username, this is my credentials:

Username: <tenancy-namespace/
<user-name - email address>

For Password, I already tried the following:
•Authorization Token from OCI Console > Profile > Resources > Auth Tokens
•Tried all the three files of Profile Config from oci session authenticate command

All of the passwords that I input have unauthorized issues, I can’t connect to OCI and use docker push. These are the errors:

denied:Anonymous users are only allowed read access on public repos

denied: Anonymous users are only allowed read access on public repos

What is the correct password to input?

Thank you in advance for answering! :slight_smile:

This is my reference for doing this task:

Are you sure the tag you try to push matches the registry/repo name?

Please share the registry and repo name you try to push the image for and the exact command you use to push the image. Feel free to anonymize the repo name while sharing the above information.

Yes, I carefully followed the instructions from my reference.

This is the screenshot of where I got the registry, repo name, and tenant-namespace. (Need to anonymize some information, sorry)

These are the screenshots of errors that I’ve encountered on CLI.

I guess you will have to wait for someone experience with the oc container registry.

If the credentials permit write access to the repo, and the image was tagged like the repo, it should work.
I have no idea how the OC container registries handles things. Though, the problems you experience appear to be OC specific. You might want to consult their documentation or raise a support ticket.

noted on this, thanks!

I had the same problem, and I discovered that I had to use “oracleidentitycloudservice/” prefix when entering the username.

For example :

docker login --username=<tenancy-name>/oracleidentitycloudservice/<email-address>