Docker Community Forums

Share and learn in the Docker community.

Docker Mac: Not able to ping my xhyve VM

docker

(Brajpanda) #1

Expected behavior

ping 127.0.0.1 should work.

Actual behavior

It times out.

Information

cat /etc/resolver/dev`
nameserver 127.0.0.1
port 53000

dns-sd -G v4 foo.dev
DATE: —Tue 12 Jul 2016—
23:19:31.179 …STARTING…
Timestamp A/R Flags if Hostname Address TTL
23:19:31.181 Add 2 0 foo.dev. 127.0.0.1 15

scutil --dns
DNS configuration

resolver #1
search domain[0] : domain.name
nameserver[0] : 103.8.45.5
nameserver[1] : 103.8.46.5
nameserver[2] : fe80::217:7cff:fe5b:4be9%en0
if_index : 4 (en0)
flags : Request A records, Request AAAA records
Reachable

resolver #2
domain : local
options : mdns
timeout : 5
flags : Request A records, Request AAAA records
Not Reachable
order : 300000

resolver #3
domain : 254.169.in-addr.arpa
options : mdns
timeout : 5
flags : Request A records, Request AAAA records
Not Reachable
order : 300200

resolver #4
domain : 8.e.f.ip6.arpa
options : mdns
timeout : 5
flags : Request A records, Request AAAA records
Not Reachable
order : 300400

resolver #5
domain : 9.e.f.ip6.arpa
options : mdns
timeout : 5
flags : Request A records, Request AAAA records
Not Reachable
order : 300600

resolver #6
domain : a.e.f.ip6.arpa
options : mdns
timeout : 5
flags : Request A records, Request AAAA records
Not Reachable
order : 300800

resolver #7
domain : b.e.f.ip6.arpa
options : mdns
timeout : 5
flags : Request A records, Request AAAA records
Not Reachable
order : 301000

resolver #8
domain : dev
nameserver[0] : 127.0.0.1
port : -12536
flags : Request A records, Request AAAA records
Reachable, Local Address, Directly Reachable Address

DNS configuration (for scoped queries)

resolver #1
search domain[0] : domain.name
nameserver[0] : 103.8.45.5
nameserver[1] : 103.8.46.5
nameserver[2] : fe80::217:7cff:fe5b:4be9%en0
if_index : 4 (en0)
flags : Scoped, Request A records, Request AAAA records
Reachable

Other Info

I have docker-machine as well as Docker for Mac. However all docker-machine VMs are stopped now.


(Brajpanda) #2

Phew! Never mind! My firewall was blocking all incoming connections somehow. I opened it up and it all worked fine.