Docker Community Forums

Share and learn in the Docker community.

"docker-machine create" hung at Waiting for host to start ...?


#1

As the title says, the command docker-machine create I used is hung forever at Waiting for host to start
Here is the full command:

docker-machine create -d hyperv --hyperv-disk-size 2048 --hyperv-memory 1024 master

Here is some info about my environment:

– OS: Windows 10 Enterprise - 64 bit (1803 / 17134.648) with Hyper-v enabled
– Docker Desktop for Windows latest version at the time of this post. However when trying the command above this is not running (but the services docker and com.docker.service are still running).
– The Docker Desktop for Windows is switched to use Linux container.

Actually while it being hung at Waiting for host to start …, I can check the Hyper-v manager and see that the machine is created and running there. I can even use the Connect function of the manager to open the machine’s screen and I can actually see a ready terminal there (looks like a Linux terminal), typing some docker-related commands shows that it seems to be a working machine.

However from the host machine (Windows 10), when I try using the command docker-machine env to switch to the machine context, it reports an error like this:

Error checking TLS connection: IP not found

I’m really stuck at this message and don’t know how to solve this.
I hope someone here could help me with this, thanks.