Docker Community Forums

Share and learn in the Docker community.

Docker-Machine with Amazon. Provisionning problem

amazonwebservices

(Djans) #1

I am struggling with the provisionning of Amazon instance using docker-machine.I constantly have the same problem : Here is my command ( keys and secret are good but not printed here. This is not the issue )

$ docker-machine create -d amazonec2 --swarm --swarm-image=“swarm” --swarm-master --swarm-discovery=“consul://$(docker-machine ip mh-key5):8500” --engine-opt=“cluster-store=consul://$(docker-machine ip mh-key5):8500” --engine-opt=“cluster-advertise=eth1:2376” --amazonec2-zone c --amazonec2-access-key AXXXXXXXXXXX --amazonec2-secret-key XXXXXXXXXXXXXXXXXXXX/ --amazonec2-vpc-id vpc-xxxxxx --amazonec2-ami=“ami-12663b7a” --amazonec2-ssh-user ec2-user --amazonec2-private-address-only=true mhs-demoa

and here is the error message

Running pre-create checks…
Creating machine…
Waiting for machine to be running, this may take a few minutes…
Machine is running, waiting for SSH to be available…
Detecting operating system of created instance…
Provisioning created instance…
Error creating machine: Error running provisioning: exit status 1

Sometimes the error is a

Error creating machine: Error waiting for SSH: Too many retries waiting for SSH

I have tried with/without : –amazonec2-private-address-only=true
also tried with/without : –amazonec2-ssh-user ec2-user

No success !!! Any idea ?


(Borisrousseau) #2

Hello,

I have the exact same issue.
Did you figure out how to solve it ?

Thanks


(Nathan Le Claire) #3

What does the output with --debug say (be careful to remove any secrets)