Docker on Windows behind a proxy with authentication. Not able to pull images

Dear Docker-Team, I’m struggeling getting docker pull images behind a proxy on a windows machine. I allways get the ErrorMessage: “docker: Error response from daemon: Get "": Proxy Authentication Required.” I already configured Proxy in config file, which is located c:\Users\myUser\.docker\config.json

    "credsStore": "desktop",
    "proxies": {
      "default": {
        "httpProxy": "http/yyyyy:xxxxx@myproxy:81",
        "httpsProxy": "http/yyyyy:xxxxx@myproxy:81",
        "noProxy": "localhost,"

But still getting proxy auth failed.
I also configured the Docker Desktop App under settings with proxy and credentials.
Here are some Logs:

[2022-04-12T14:53:14.102244700Z][com.docker.backend.exe][I] (07d3e3da) e89d8cc1-BackendAPI S->C 6ebe2a5f-ProxyPKG GET /registry/access (0s): {"allowed":[{"DNS":"","IP":{"IP":"","Mask":"AAAAAA=="},"Type":1,"value":""},{"DNS":".","IP":{"IP":"","Mask":null},"Type":3,"value":"."}],"enabled":false,"refresh_after":"2022-04-13T04:53:14.1017016+02:00","refresh_grace_period_ends":"2022-04-13T16:53:14.1017016+02:00","refresh_grace_period_interval":3600000000000}
[2022-04-12T14:53:14.102838100Z][com.docker.proxy.exe][I] (07d3e3da) 6ebe2a5f-ProxyPKG C<-S e89d8cc1-BackendAPI GET /registry/access (1.784ms): {"allowed":[{"DNS":"","IP":{"IP":"","Mask":"AAAAAA=="},"Type":1,"value":""},{"DNS":".","IP":{"IP":"","Mask":null},"Type":3,"value":"."}],"enabled":false,"refresh_after":"2022-04-13T04:53:14.1017016+02:00","refresh_grace_period_ends":"2022-04-13T16:53:14.1017016+02:00","refresh_grace_period_interval":3600000000000}
time="2022-04-12T14:53:14.119710206Z" level=info msg="ethernet: Connected Ethernet interface f6:16:36:bc:f9:c6"
time="2022-04-12T14:53:14.119710206Z" level=info msg="udp: UDP interface connected on"
time="2022-04-12T14:53:14.129273414Z" level=info msg="http: HTTP proxy --> (Proxy): CONNECT "
time="2022-04-12T14:53:14.129998207Z" level=info msg="http: HTTP proxy --> (Proxy): Successfully connected to"
time="2022-04-12T14:53:14.129998207Z" level=info msg="http: Outgoing.Request.write"
time="2022-04-12T14:53:14.130559921Z" level=info msg="http:"
time="2022-04-12T14:53:14.141627073Z" level=info msg="http: HTTP proxy <-- (Proxy): HTTP/1.1 407 Proxy Authentication Required"
time="2022-04-12T14:53:14.141996622Z" level=info msg="http: HTTP proxy <-- (Proxy): proxying body"
[2022-04-12T14:53:14.156155300Z][com.docker.proxy.exe][I] proxy << POST /v1.41/images/create?fromImage=docker%2Fgetting-started&tag=latest (55.6941ms)

I dont know what else I can do.

Any success? I have the same issue.

I know it is an old post and it is possible you already solved it, but I edited the post to be more readable.

Please, use </> button to share codes, terminal outputs, error messages or anything that can contain special characters which would be interpreted by the MarkDown filter. Use the preview feature to make sure your text is formatted as you would expect it and check your post after you have sent it so you can still fix it. I edited your post.

I have seen many similar issues, but I don’t use Docker Desktop with proxies so I have never really configured it that way. Your logs are really helpful. It shows us that domain name resolution works and the network connection works too, but the proxy server requires authentication. I think the only missing info is which log is this. I found this old answer:

I don’t know if it helps. Maybe there is one small detail which helps. If you still watching this topic and you could solve this issue an other way, please share it with @arturdrzeniekbfg :slight_smile:

@arturdrzeniekbfg Are you sure you have the same issue and not just similar? Can you share your exact error messages and what you tried to do?

For me, the problem is very similar.
I tried entering configuration in Docker Desktop> Settings> Proxies.
I also tried adding the HTTP_PROXY and HTTPS_PROXY environment variables.
I tried HTML encoded password and without encoding because it contains the special character “!”, so I put %21 instead.
Also setting httpProxy in httpsProxy in c:\Users\myUser\.docker\config.json did not work.
The configuration in Docker Desktop> Settings> Proxies only fixes the problem with logging into my account.
But still executing docker pull image in powershell returns an error
Error response from daemon: Get "": Proxy Authentication Required

Here are some logs from Docker

[2022-07-27T11:44:45.825936300Z][com.docker.backend.exe][W] failed to lookup name exists but no relevant records
[2022-07-27T11:44:45.852677100Z][com.docker.backend.exe][W] failed to lookup name exists but no relevant records
[2022-07-27T11:44:45.855374500Z][com.docker.backend.exe][W] failed to lookup name exists but no relevant records
[2022-07-27T11:44:45.859102249Z][com.docker.vpnkit.exe][info] ethernet: Connected Ethernet interface f6:16:36:bc:f9:c6
[2022-07-27T11:44:45.859102249Z][com.docker.vpnkit.exe][info] udp: UDP interface connected on
[2022-07-27T11:44:45.864315032Z][com.docker.vpnkit.exe][info] http: HTTP proxy --> (Proxy): CONNECT 
[2022-07-27T11:44:45.880073547Z][com.docker.vpnkit.exe][info] http: HTTP proxy --> (Proxy): Successfully connected to
[2022-07-27T11:44:45.880073547Z][com.docker.vpnkit.exe][info] http: Outgoing.Request.write
[2022-07-27T11:44:45.881083011Z][com.docker.vpnkit.exe][info] http:
[2022-07-27T11:44:45.925359964Z][com.docker.vpnkit.exe][info] http: HTTP proxy <-- (Proxy): HTTP/1.1 407 Proxy Authentication Required
[2022-07-27T11:44:45.926231861Z][com.docker.vpnkit.exe][info] http: HTTP proxy <-- (Proxy): proxying body
[2022-07-27T11:44:45.930991400Z][com.docker.proxy.exe][I] proxy << POST /v1.41/images/create? (241.7514ms)
[2022-07-27T11:44:45.932568400Z][VpnKitBridge      ][Info   ] msg="error CloseWrite to: Trwa zamykanie potoku."
[2022-07-27T11:44:45.945806200Z][com.docker.backend.exe][I] (e773db44) aca8eb0d-CLIAPI S<-C Go-http-client/1.1 POST /usage
[2022-07-27T11:44:45.945806200Z][com.docker.backend.exe][I] (e773db44) aca8eb0d-CLIAPI S<-C Go-http-client/1.1 bind: {"command":"pull","context":"moby","source":"cli","status":"failure"}
[2022-07-27T11:44:45.946318600Z][com.docker.backend.exe][I] (e773db44) aca8eb0d-CLIAPI S->C Go-http-client/1.1 POST /usage (512.1µs): OK

I just installed older version 4.3.2 of Docker Desktop and I was able to pull image only with proxy configuration saved in Docker Desktop UI ( Docker Desktop> Settings> Proxies)…
So there is a problem with version 4.10.2.

Would you share this issue on GitHub? I found this similar still open issue:

Since you found a working version it could help to resolve the issue.