Docker Community Forums

Share and learn in the Docker community.

Docker Playground Error after BuildX

When i run OpenSpeedTest Docker image in Docker Playground i am getting

net::ERR_CONTENT_LENGTH_MISMATCH 200 (OK)

Results failed GET request.

Commands i used

docker run --restart=unless-stopped --name=openspeedtest -d -p 80:8080 openspeedtest/latest

Recently i used buildX

docker buildx build -t openspeedtest/latest:speedtest --platform linux/amd64,linux/arm64,linux/ppc64le,linux/s390x,linux/386,linux/arm/v7 . --push

When i run locally it is working fine.
upload://m2VdwBHXmGh7sjfBdW3DD12j8BA.jpeg
Why it is behaving differently on some machines ?
I am doing something wrong here?

Added buildx binary manually - worth noting I couldn’t use buildx simply by specifying export DOCKER_CLI_EXPERIMENTAL=enabled.
Arch Linux
Docker version 19.03.5-ce, build 633a0ea838

HIGHLIGHTED ERROR
failed to solve: rpc error: code = Unknown desc = failed to solve with frontend dockerfile.v0: failed to build LLB: failed to load cache key: failed to do request: Head https://registry-1.docker.io/v2/continuumio/miniconda/manifests/latest: dial tcp: lookup registry-1.docker.io on 192.168.1.1:53: read udp 172.17.0.2:40167->192.168.1.1:53: i/o timeout

How to solve this issue.