Docker Community Forums

Share and learn in the Docker community.

Docker prune operation is already running

Hi,

When I run docker system prune --force --volumes I got the following message:
Error response from daemon: a prune operation is already running.

After some research on Internet, I found something about “zombie containers” but none of the tips shared by the community worked for me.

In all of these tips there is always the next command to execute to get the PID of the container:
ps -aux | grep <container_id>.
But, any process is returned by the command.
When I run docker container ls, I can see the container, but when I run docker container inspect <container_id> I can’t get my console back until I press ctrl+c.

$ docker version

Client: Docker Engine - Community
 Version:           20.10.5
 API version:       1.41
 Go version:        go1.13.15
 Git commit:        55c4c88
 Built:             Tue Mar  2 20:18:05 2021
 OS/Arch:           linux/amd64
 Context:           default
 Experimental:      true

Server: Docker Engine - Community
 Engine:
  Version:          20.10.5
  API version:      1.41 (minimum version 1.12)
  Go version:       go1.13.15
  Git commit:       363e9a8
  Built:            Tue Mar  2 20:16:00 2021
  OS/Arch:          linux/amd64
  Experimental:     true
 containerd:
  Version:          1.4.4
  GitCommit:        05f951a3781f4f2c1911b05e61c160e9c30eaa8e
 runc:
  Version:          1.0.0-rc93
  GitCommit:        12644e614e25b05da6fd08a38ffa0cfe1903fdec
 docker-init:
  Version:          0.19.0
  GitCommit:        de40ad0

I’m in swarm mode.

Sorry, I don’t know the steps to reproduce the problem because I don’t know how it happens

Thanks.