Docker pull behind HTTP Proxy is broken - Debian 11

Hi all,

I am helpless at the moment, so I am asking here for help.
I am running at work a debian 10 server with docker installed. This server is hosting our password manager in docker. This server has no direct internet connection. It has to use our company HTTP(S) Proxy with authentication required. It was not trivial, but I managed to get the password manager up and running in docker. The update process worked without a problem until now. I think, the only thing changed on the system over time, is the docker version.

I cant pull any image. When I try “docker run hello-world” I get this error:

docker: Error response from daemon: Get “”: net/http: request canceled while waiting for connection (Client.Timeout exceeded while awaiting headers).

I followed this guide, to set the proxy settings for docker:

What am I doing wrong? It worked like a charm…:frowning:

I also have setup a lab environment at home, with the same result. I will answer to this thread, with the details.

Thanks in advance. Maybe I am not the only one with this problem.

(post deleted by author)

(post deleted by author)