Docker Community Forums

Share and learn in the Docker community.

Docker Pull Error response from daemon i/o timeout


(Jhampson) #1

Expected behavior

WARNING: login credentials saved in /home/ec2-user/.docker/config.json
Login Succeeded
latest: Pulling from awslocationname
17522f47de58: Pulling fs layer
6d030e217246: Pulling fs layer
17522f47de58: Verifying Checksum
17522f47de58: Download complete
17522f47de58: Pull complete
6d030e217246: Verifying Checksum
6d030e217246: Download complete
6d030e217246: Pull complete

Actual behavior

Error response from daemon i/o timeout

Additional Information

This had been working when I was using Docker ver 1.09. when I updated to 1.11.2, this started happening and I am no longer successful from pulling form the AWS ECS repository.
My app servers that ares till running 1.09 work flawlessly and produce the expected result.
I am behind a proxy. I presume that the version 1.09 read from the system environment for proxy info. I don’t know what changed in 1.11.

I also tried creating a brand new Amazon linux box that started with 1.11 as opposed to 1.09 and updating to 1.11. … no luck. again, what am I missing? what changed in 1.11 that my pull no longer works?

[ec2-user@ip-10-168-2-43 sysconfig]$ sudo docker info
Containers: 0
Running: 0
Paused: 0
Stopped: 0
Images: 0
Server Version: 1.11.2
Storage Driver: devicemapper
Pool Name: docker-202:1-263574-pool
Pool Blocksize: 65.54 kB
Base Device Size: 10.74 GB
Backing Filesystem: xfs
Data file: /dev/loop0
Metadata file: /dev/loop1
Data Space Used: 11.8 MB
Data Space Total: 107.4 GB
Data Space Available: 30.28 GB
Metadata Space Used: 581.6 kB
Metadata Space Total: 2.147 GB
Metadata Space Available: 2.147 GB
Udev Sync Supported: true
Deferred Removal Enabled: false
Deferred Deletion Enabled: false
Deferred Deleted Device Count: 0
Data loop file: /var/lib/docker/devicemapper/devicemapper/data
WARNING: Usage of loopback devices is strongly discouraged for production use. Either use --storage-opt dm.thinpooldev or use --storage-opt dm.no_warn_on_loop_devices=true to suppress this warning.
Metadata loop file: /var/lib/docker/devicemapper/devicemapper/metadata
Library Version: 1.02.93-RHEL7 (2015-01-28)
Logging Driver: json-file
Cgroup Driver: cgroupfs
Plugins:
Volume: local
Network: bridge null host
Kernel Version: 4.4.11-23.53.amzn1.x86_64
Operating System: Amazon Linux AMI 2016.03
OSType: linux
Architecture: x86_64
CPUs: 1
Total Memory: 995.4 MiB

Steps to reproduce the behavior

  1. run a pull from an aws ecs repository behind a proxy on Docker version 1.09.
  2. do a yum update - and update your Docker to 1.11
  3. run the same command again and you should receive an i.o timeout.

Pulling Docker images: i/o timeout
Need to specify proxy settings
Docker pull timeout
(Jhampson) #2

Confirmed that this is not an AWS problem.
I am unable to pull using the test: docker run hello-world

in Docker 1.9.1 the command works and can pull down the hello-world package to run.
I run it in 1.11.1 with the same proxy settings and I get "You may want to check your internet connection or if you are behind a proxy"
Yes correct I am behind a proxy, why aren’t you using my proxy settings!??!!!

----------------------UPDATE-------------------------

All - this seems to be fixed in Docker 1.12
https://get.docker.com/builds/Linux/x86_64/docker-1.12.1.tgz

if you get a storage driver error use dockerd -s overlay2 &

Then make sure you have your HTTP_PROXY environment variable set prior to starting the dockerd. If it is already started, stop it and start again after you set the env variable.