Docker Community Forums

Share and learn in the Docker community.

Docker push - Error - requested access to the resource is denied

Hello, I believe you need to add your user name with the images name before building the image

docker build -t username/imagename:latest .
docker push username/imagename

try these commands, it will solve your problem

1 Like

The caveats that you give are great.

บาคาร่า
บาคาร่าออนไลน์
baccarat

After logout action it’s works for me.

hello from 2021, it works on my gitlab CI. thank you. i suffered hours time trying to solve this problem.
the solution from you is the registry server is placed on last line, mine was in first line " docker login index.docker.io -u user -p passw"

Thanks… This worked for me!

this worked for me… :slight_smile:
was using / in the name…

for me I login to dockerhub as a root user with sudo – su and docker login and I am able to push even using ansible to dockerhub.

Thank you you saved my life

Yeap, it makes sense.Thanks

Hi Gabriel, what worked for me was that I used my docker hub username as a part of TARGET_IMAGE name when creating tag image to be pushed to docker hub, here the example:

example:
docker tag SOURCE_IMAGE[:TAG] dockerusername/TARGET_IMAGE[:TAG]

after that push to Your repository should work fine if You logged in.