Docker Community Forums

Share and learn in the Docker community.

Docker registry ui cannot reach private docker registry V2

(Tezarin) #1

Hi all,

I am running a private docker registry: docker run -d -e SEARCH_BACKEND=SQLAlchemy -p 5000:5000 registry:2

I am also running a Docker registry UI on the same host: docker run -p 80:8080 -it -e APP_CONTEXT=ui -e REG1= atcol/docker-registry-ui

But the UI cannot find the registry on port 5000. Curl returns 404 page not found and I cannot access and localhost:5000 via the browser either.

curl -v -X GET http://localhost:5000/v2/search

  • Hostname was NOT found in DNS cache
  • Trying…
  • Connected to localhost ( port 5000 (#0)

GET /v2/search HTTP/1.1
User-Agent: curl/7.35.0
Host: localhost:5000
Accept: /

< HTTP/1.1 404 Not Found
< Content-Type: text/plain; charset=utf-8
< Docker-Distribution-Api-Version: registry/2.0
< Date: Fri, 17 Jul 2015 19:13:45 GMT
< Content-Length: 19
404 page not found

  • Connection #0 to host localhost left intact

Is there another setting I have to configure before my UI can see the existing registry?

Thanks in advance

(yvesdufour) #2

enter link description herev2 API is different … see doc

check if curl -v http://localhost:5000/v2/ returns correctly an empty JSON

(Tezarin) #3

Thanks, it returns:
$ curl -v http://localhost:5000/v2/

  • Hostname was NOT found in DNS cache
  • Trying…
  • Connected to localhost ( port 5000 (#0)

GET /v2/ HTTP/1.1
User-Agent: curl/7.35.0
Host: localhost:5000
Accept: /

< HTTP/1.1 200 OK
< Content-Length: 2
< Content-Type: application/json; charset=utf-8
< Docker-Distribution-Api-Version: registry/2.0
< Date: Mon, 20 Jul 2015 21:05:58 GMT

  • Connection #0 to host localhost left intact

I have the registry:2 docker container running, and at the same time I have the registry-ui docker container running, too. The problem is I can’t add my registry:2 as a new registry inside the UI. I just like to be able to use the UI to access my registry:2 docker container, is that even possible? if so, please let me know how?


(yvesdufour) #4

good … your docker registry seems to run correctly…

I also tried to use the latest docker-ui without any success it was designed for V1 … and should be updated to run with v2… check issues on github for the docker-ui … it may not be ready for V2…
I gave up using it … I’m working on using another docker-ui ( Rails version ) which seems to be ready for v2… currently I’m trying to set up S3 storage for my V2 registry … few examples available so it takes time …

(Tezarin) #5


Thanks for your reply. Can you post a link to the UI you are currently using? Is that ready for V2? I have no luck with the docker-ui. All I need is to have a API to manage my registry.

Thanks in advance

(yvesdufour) #6

I am looking at ( looks promising…)

it seems that Konrad is working on making his ui V2 compatible


(Ryan Trauntvein) #7

Work in progress but SUSE is also doing a registry V2 Frontend

(yvesdufour) #8

yes , I’m also tracking it … thanks

(Tezarin) #9

Great, thanks I’ll check out Panamax. Please keep me posted if you find a good API to manage the registry.

(Tezarin) #10

Hi again,

Has anyone tried any of the options mentioned above? Which one do you recommend?


(Zoumana) #11

Hi everybody.

I have done many researches on Google in order to solve my following problem.

I can not access
I get the following error

message "authentication required"

I don’t know how to solve my problem.

Thank you for your help