Docker run hello-world error


I’m just getting started with docker. I’m following the instructions specified here

I installed docker (1.10.2) on windows 10 & ran docker run hello-world . But, I’m getting an authentication error while the tutorial doesn’t mentioned anything about it.

Here’s the message I received.

$ docker run hello-world Unable to find image 'hello-world:latest' locally docker: Error response from daemon: Authentication is required: Get unauthorized: incorrect username or password. See 'C:\Program Files\Docker Toolbox\docker.exe run --help'.

I searched google & SO but couldn’t find anything exactly similar to this.


1 Like

For anyone looking for the answer,

1 Like

Try this:

  1. Open up shell in administrator mode
  2. Enter docker login
  3. Enter Docker ID & Password.
    4.Execute docker info
  4. Execute docker run hello-world.

This should work when you have already created Ducker ID. Get it here=>>

1 Like

I had the same problem. It turns out that the CLI (docker login) needs your USERNAME (not e-mail address), even though the e-mail address works for the docker web site or desktop UI.

1 Like

In Mac book Terminal, Enter “docker login” and then enter the docker ID not the email ID that you will use generally for login.
and then enter the password it will work.

great answer, works for me, Thanks!!

Is it mandatory as soon as laptop got rebooted we need to authenticate ourself every time?
I dint faced this issue on Ubuntu desktop but i faced this issue on my Mac

I tried the above options still i am seeing attached error. Can someone help me on this.

D .

1 Like

This is clearly a doku bug! It should hightlight that the latest tag points to a linux image, and a different tag is needed for windoes.

You might want to try docker run hello-world:nanoserver or another nanoserver:{version} tag that matches the docker engine under the hood.

i was using direct installing from Ubuntu 18.04.3 LTS repositories,was in a mess even for me the docker would be giving out the same error.
i tried installing all confusing docker.ce,
but then
i uninstalled everything and followed steps from the given link thanks