Docker Community Forums

Share and learn in the Docker community.

Docker service won’t start after changing data-root to clustered shared volume


(Daveq) #1

Hello,
I am trying to change the data-root location to a clustered shared volume. After I changed the location in daemon.json the docker service won’t start. The following message appears in the eventlog:

Unable to get the full path to root (C:\ClusterStorage\Volume1\dockdata): failed to canonicalise path for C:\ClusterStorage\Volume1\dockdata: GetFileAttributesEx C:\ClusterStorage\Volume{fb035b0f-f594-44bc-8214-b3d627a89555}\dockdata: The system cannot find the file specified.

daemon.json:
{
“experimental”: true,
“data-root”: “C:\ClusterStorage\Volume1\dockdata”
}

When I change the location to a map on the C drive (for example “data-root”: “C:\dockdata” it works fine.

Anyone an idea how to solve this problem? Any help would be appreciated

Output docker version:
Client:
Version: 17.06.1-ee-2
API version: 1.30
Go version: go1.8.3
Git commit: 8e43158
Built: Wed Aug 23 21:16:53 2017
OS/Arch: windows/amd64

Server:
Version: 17.06.1-ee-2
API version: 1.30 (minimum version 1.24)
Go version: go1.8.3
Git commit: 8e43158
Built: Wed Aug 23 21:25:53 2017
OS/Arch: windows/amd64
Experimental: true

Output docker info:
Containers: 0
Running: 0
Paused: 0
Stopped: 0
Images: 1
Server Version: 17.06.1-ee-2
Storage Driver: windowsfilter
Windows:
Logging Driver: json-file
Plugins:
Volume: local
Network: l2bridge l2tunnel nat null overlay transparent
Log: awslogs etwlogs fluentd json-file logentries splunk syslog
Swarm: inactive
Default Isolation: process
Kernel Version: 10.0 14393 (14393.1198.amd64fre.rs1_release_sec.170427-1353)
Operating System: Windows Server 2016 Standard
OSType: windows
Architecture: x86_64
CPUs: 16
Total Memory: 79.96GiB
Name: docker1
ID: JVC5:UNUQ:UO2K:LQHI:VRS2:YW3O:Q7QX:VZ5S:6TQL:JYVD:Z2UU:IG4U
Docker Root Dir: C:\ProgramData\docker
Debug Mode (client): false
Debug Mode (server): false
Registry: https://index.docker.io/v1/
Experimental: true
Insecure Registries:
127.0.0.0/8
Live Restore Enabled: false


(Ddkserv) #2

Hi,

I had the same issue.
I found that you have to use the right " and also escape the \ in the JSON.
Here is the data-root from my configuration that work:
"data-root": "D:\\ProgramData\\Docker"

Thanks.