Dear Docker developers,
I was wondering if you’d reconsider the current naming convention for services deployed via docker stack (or at least support passing a different naming strategy as an argument).
Currently, deploying a stack named demo will start services called demo_service1, demo_service2, etc.
The problem is, demo_service1 is actually the URL at which that service can be reached by demo_service2, and vice versa, per docker swarm routing policy (which is awesome, btw).
Sadly though, underscores in hostnames are NOT a good idea, as documented in multiple places, and consequently in many programming languages, Java 8 included, parsing an url with an _ in it fails.