Docker stopped installing and working after the virtual machine freezes

Good day!
I’m a beginner in the Linux world. I installed a docker, a docker – compose, several containers and a portainer. Everything worked. At an unlucky moment, my laptop win7 with running vmware workstation 15 and Ubuntu 20 froze. After restarting, it became clear that containerd was damaged. I fixed it. But the Docker stopped working. Any actions aimed at removing traces and reinstalling lead to one result – an error. I don’t know where to look next.

isnt help
sudo dpkg --configure -a
sudo apt-get install -f
sudo apt-get remove --purge docker-ce
sudo apt autoremove
sudo ls -l /var/lib/dpkg/info | grep -i docker-ce

just hung
sudo docker version
sudo docker ps
sudo docker info

user@user-pc:~$ sudo service docker status
[в—Џ docker.service - Docker Application Container Engine
Loaded: loaded (/lib/systemd/system/docker.service; enabled; vendor prese>
Active: activating (start) since Mon 2023-04-24 22:56:46 +07; 30s ago
TriggeredBy: в—Џ docker.socket
Main PID: 12979 (dockerd)
Tasks: 7
Memory: 20.8M
CPU: 258ms
CGroup: /system.slice/docker.service
в””в”Ђ12979 /usr/bin/dockerd -H fd:// --containerd=/run/containerd/co>

user-pc dockerd[12979]: time="2023-04-24T22:57:12.810811678+07>
user-pc dockerd[12979]: time="2023-04-24T22:57:12.810934367+07>
user-pc dockerd[12979]: time="2023-04-24T22:57:15.946093549+07>
user-pc dockerd[12979]: time="2023-04-24T22:57:15.946211918+07>
user-pc dockerd[12979]: time="2023-04-24T22:57:15.946269799+07>
user-pc dockerd[12979]: time="2023-04-24T22:57:15.946310686+07>
user-pc dockerd[12979]: time="2023-04-24T22:57:15.946573950+07>
user-pc dockerd[12979]: time="2023-04-24T22:57:15.946640007+07>
user-pc dockerd[12979]: time="2023-04-24T22:57:15.946687655+07>
user-pc dockerd[12979]: time="2023-04-24T22:57:15.946721986+07>
lines 1-22/22 (END)

Job for docker.service failed because the control process exited with error code.
See “systemctl status docker.service” and “journalctl -xeu docker.service” for details.
invoke-rc.d: initscript docker, action “start” failed.
в—Џ docker.service - Docker Application Container Engine
Loaded: loaded (/lib/systemd/system/docker.service; enabled; vendor preset: enabled)
Active: activating (auto-restart) (Result: exit-code) since Mon 2023-04-24 23:02:11 +07; 16ms ago
TriggeredBy: в—Џ docker.socket
Process: 13676 ExecStart=/usr/bin/dockerd -H fd:// --containerd=/run/containerd/containerd.sock (code=exited, status=1/FAILURE)
Main PID: 13676 (code=exited, status=1/FAILURE)
CPU: 501ms