Docker Community Forums

Share and learn in the Docker community.

Docker Toolbox: Containers working, but i cannot access one of them

Hello, greetings from Brazil!

I’m using Docker Toolbox because Docker Desktop not works well in my windows 10 with android emulator (Genymotion).

Follow the instructions to install ToolBox here: https://docs.docker.com/toolbox/toolbox_install_windows/

But i’m not able to connect to my container, so i try to check the containers by run docker-compose ps here the result:

          Name                     Command                State              Ports
-------------------------------------------------------------------------------------
docker_graphql-engine_1     graphql-engine serve           Up  0.0.0.0:8080->8080/tcp
docker_postgres_1           docker-entrypoint.sh postgres  Up  0.0.0.0:5432->5432/tcp
docker_sca-graphql-engine_1 graphql-engine serve           Restarting

docker_graphql-engine_1 Working and connecting fine at port 8080

docker_postgres_1 Working and connecting fine at port 5432

docker_sca-graphql-engine_1 never starts; just stay with Restarting state. The other containers works, but i’m not able to connect them

Do I missed something?

Below my docker-container.yaml:

version: '3.6'
services:
  postgres:
    image: postgres:12
    ports:
    - "5432:5432"
    restart: always
    volumes:
    - db_data:/var/lib/postgresql/data
    environment:
      POSTGRES_PASSWORD: postgrespassword
  graphql-engine:
    image: hasura/graphql-engine:v1.2.0-beta.2
    ports:
    - "8080:8080"
    depends_on:
    - "postgres"
    restart: always
    environment:
      HASURA_GRAPHQL_DATABASE_URL: postgres://postgres:postgrespassword@postgres:5432/postgres
      HASURA_GRAPHQL_ENABLE_CONSOLE: "true" # set to "false" to disable console
      HASURA_GRAPHQL_ENABLED_LOG_TYPES: startup, http-log, webhook-log, websocket-log, query-log
  sca-graphql-engine:
    image: hasura/graphql-engine:v1.1.0
    ports:
    - "8181:8080"
    depends_on:
    - "postgres"
    restart: always
    environment:
      HASURA_GRAPHQL_DATABASE_URL: postgres://postgres:postgrespassword@postgres:5432/sca
      HASURA_GRAPHQL_ENABLE_CONSOLE: "true" # set to "false" to disable console
      HASURA_GRAPHQL_ENABLED_LOG_TYPES: startup, http-log, webhook-log, websocket-log, query-log
volumes:
  db_data:

Have you tried to check the logs for that service?
docker logs docker_sca-graphql-engine_1

Hello.

Yes checked now… the problem is that i was using the wrong password for postgress connection that this container needs. Fix it and problem solved. Tx

1 Like