Docker tools on iMac 2009


I have an iMac 2009, 11.1 core i7 under 10.15.7

Docker Desktop doesn’t work because Cpu is not compatible. My sysctl kern.hv_support = 0.

So I tried the solution using Docker Toolbox. Kinematic doesn’t work but Docker Quickstart terminal yes. I can start docker run hello-world and it works… Well, ok.

So I’ve installed Portainer using this in the terminal:
docker volume create portainer_data

And this:
docker run -d -p 8000:8000 -p 9443:9443 --name portainer --restart=always -v /var/run/docker.sock:/var/run/docker.sock -v portainer_data:/data portainer/portainer-ce:latest

A “docker ls” command shows portainer is up and working

But, I can’t display localhost:9443, http or https…

Could you help me to find how to display my portainer webpage ? What could I do ?

Kind regards

That line raises multiple questions.

  • What is “can’t display”?
    • From where? Browser? Terminal?
    • What do you see on the screen? White page? Error message?
  • Port 9443 is not “http or https”, it is only for https. It is not a question, but a fact.
  • Have you tried port 8000?
  • Is the portainer container running? Mak sure it didn’t stop before you could try to open it frmo a browser.
  • If it is running, did you check the container logs?

Thank you for your answer.

  • This is the webpage on the browser (Firefox and Safari) that doesn’t display. Empty page, like if there is no server.
  • Yes, 9443 is https. When I wrote https and http, it was to mention 9443 and 8000. I tried both and nothing happens.
  • The portainer container is working. I can see the status and the uptime using “docker ps”. Even after I tried all the ports, the container is still up.

How can I look at the container logs ? I have to see the file here /var/lib/docker/containers/ ?
If yes, I’ll check tomorrow morning.

That’s a kind of question to which you can find the answr pretty quickly on Google using simple keywords (or running docker ---help) like “docker containr logs”. Which is actually the command. At least in the the current version of Docker. You probably have an odler Docker which I wouldn’t recommend to use as many images could be incompatible with the docker daemon.

Check the docker version by runing the following commands:

docker info
docker version

Never even try to do anything in that folder. Of course, if Docker Tools worked as Docker Desktop, you wouldn’t have that folder on the host.

docker version shows this:

Client: Docker Engine - Community
 Version:           19.03.1
 API version:       1.40
 Go version:        go1.12.5
 Git commit:        74b1e89
 Built:             Thu Jul 25 21:18:17 2019
 OS/Arch:           darwin/amd64
 Experimental:      false

Server: Docker Engine - Community
  Version:          19.03.12
  API version:      1.40 (minimum version 1.12)
  Go version:       go1.13.10
  Git commit:       48a66213fe
  Built:            Mon Jun 22 15:49:35 2020
  OS/Arch:          linux/amd64
  Experimental:     false
  Version:          v1.2.13
  GitCommit:        7ad184331fa3e55e52b890ea95e65ba581ae3429
  Version:          1.0.0-rc10
  GitCommit:        dc9208a3303feef5b3839f4323d9beb36df0a9dd
  Version:          0.18.0
  GitCommit:        fec3683

Docker info show this

 Debug Mode: false

 Containers: 3
  Running: 1
  Paused: 0
  Stopped: 2
 Images: 3
 Server Version: 19.03.12
 Storage Driver: overlay2
  Backing Filesystem: extfs
  Supports d_type: true
  Native Overlay Diff: true
 Logging Driver: json-file
 Cgroup Driver: cgroupfs
  Volume: local
  Network: bridge host ipvlan macvlan null overlay
  Log: awslogs fluentd gcplogs gelf journald json-file local logentries splunk syslog
 Swarm: inactive
 Runtimes: runc
 Default Runtime: runc
 Init Binary: docker-init
 containerd version: 7ad184331fa3e55e52b890ea95e65ba581ae3429
 runc version: dc9208a3303feef5b3839f4323d9beb36df0a9dd
 init version: fec3683
 Security Options:
   Profile: default
 Kernel Version: 4.19.130-boot2docker
 Operating System: Boot2Docker 19.03.12 (TCL 10.1)
 OSType: linux
 Architecture: x86_64
 CPUs: 1
 Total Memory: 1.947GiB
 Name: default
 Docker Root Dir: /mnt/sda1/var/lib/docker
 Debug Mode: false
 Experimental: false
 Insecure Registries:
 Live Restore Enabled: false
 Product License: Community Engine

Docker ps shows this

CONTAINER ID        IMAGE                           COMMAND             CREATED             STATUS              PORTS                                                      NAMES
0e3e918d0722        portainer/portainer-ce:latest   "/portainer"        6 minutes ago       Up 6 minutes>8000/tcp,>9443/tcp, 9000/tcp   portainer

I can’t add the docker logs portainer because “new users” can’t post more than 2 links in a post. I’m going to find a solution…

And docker logs portainer shows this:

2024/01/08 08:58PM INF > encryption key file not present | filename=portainer
2024/01/08 08:58PM INF > proceeding without encryption key |
2024/01/08 08:58PM INF > loading PortainerDB | filename=portainer.db
2024/01/08 08:58PM INF > no cert files found, generating self signed SSL certificates |
2024/01/08 08:58PM INF > Generated a new Chisel private key file | private-key=/data/chisel/private-key.pem
2024/01/08 20:58:46 server: Reverse tunnelling enabled
2024/01/08 20:58:46 server: Fingerprint BJUH+0ZgIYE4ldp+1H0Qk/qh+NtuvtKgnbQe0HuqGTc=
2024/01/08 20:58:46 server: Listening on
2024/01/08 08:58PM INF > starting Portainer | build_number=35428 go_version=1.20.5 image_tag=linux-amd64-2.19.4 nodejs_version=18.19.0 version=2.19.4 webpack_version=5.88.1 yarn_version=1.22.21
2024/01/08 08:58PM INF > starting HTTPS server | bind_address=:9443
2024/01/08 08:58PM INF > starting HTTP server | bind_address=:9000
2024/01/08 09:03PM INF > the Portainer instance timed out for security purposes, to re-enable your Portainer instance, you will need to restart Portainer |

I’m glad you found a solution. Thank you for using Code block. Please use it always when you share any terminal output, source code or error message. I will edit your prevous post as well.

Also thank you for the logs. As you cans ee, the last line is

the Portainer instance timed out for security purposes, to re-enable your Portainer instance, you will need to restart Portainer

When it happens, you just need to restart the container using `docker restart portainer" and try to access it from the browser and initialize the configuration before it times out again.

If it doesn’t help, then it is not the original problem and it just timed out because you couldn’t access it. If that is the case, I don’t know how I could help you, as I never used the tool that you do.

And as I suspected, the Docker version is quite old, so if you don’t have problem with it yet, I wouldn’t be surprised to see some issues in the near future.

Thank you again for your reply

I tried the “docker restart portainer” and docker ps shows portainer is running but i still can’t access to the web page https://localhost:9443.

docker ps shows this

CONTAINER ID        IMAGE                           COMMAND             CREATED             STATUS              PORTS                                                      NAMES
2e0d6af3c978        portainer/portainer-ce:latest   "/portainer"        47 hours ago        Up 4 seconds>8000/tcp,>9443/tcp, 9000/tcp   portainer

And docker logs show this:

2024/01/10 10:01AM INF > encryption key file not present | filename=portainer
2024/01/10 10:01AM INF > proceeding without encryption key |
2024/01/10 10:01AM INF > loading PortainerDB | filename=portainer.db
2024/01/10 10:01AM INF > Found Chisel private key file on disk | private-key=/data/chisel/private-key.pem
2024/01/10 10:01:23 server: Reverse tunnelling enabled
2024/01/10 10:01:23 server: Fingerprint YoyX3J2U74CEoBF6DORl9jR53jZs5mUF55zBsspDt3k=
2024/01/10 10:01:23 server: Listening on
2024/01/10 10:01AM INF > starting Portainer | build_number=35428 go_version=1.20.5 image_tag=linux-amd64-2.19.4 nodejs_version=18.19.0 version=2.19.4 webpack_version=5.88.1 yarn_version=1.22.21
2024/01/10 10:01AM INF > starting HTTPS server | bind_address=:9443
2024/01/10 10:01AM INF > starting HTTP server | bind_address=:9000

I don’t understand what goes wrong…

By the way, yes it’s an old version because this is docker tools. But on my iMac late 2009, what do you think is the best solution to use docker on my Mac ?

  • Docker Desktop is not supported. Impossible to use it because CPU is not compatible.
  • Docker Tools is working for docker in terminal, portainer is running in terminal but I can’t use it in the brower.
  • Brew ?
  • Another solution ?

Do you think I could use brew ? Or there is no way to use my old iMac for docker use ?

Some people have old Docker CE on Linux and start to see that some images don’t work. I know, you have a different problem, but the fact that old Docker versions could break after some time.

You can try to run another container using another port, using a different image, like nginx and if nothing works, we could assume that the tool you use is too old and can’t work in our days, or there was a bug which will not be fixed as it is not supported.

As an alternative, you can run a virtual machine and install Docker CE in it. Then run Portainer to have a web based gui. Install Portainer CE with Docker on Linux - Portainer Documentation

Normally I would also say that you wouldn’t be able to use Docker Desktop extensions, but it is not Docker Desktop, so you will not lose what you don’t have.

I just tried to install heimdall container. Docker ps shows status is up and works but I get the same problem. localhost:433 is impossible to reach…

I think I’ll try your solution with a linux virtual machine. Which linux do you recommand ? Alpine ?

I recommend a Linux distribution which you are familiar with and supported by Docker.

You can find the supported platforms here:

Notice that Alpine is not among those, even though the dind (Docker in Docker) image is based on Alpine, but you probably don’t want to install Docker from binaries.