Docker Community Forums

Share and learn in the Docker community.

Docker tty crashes


(Arnaud BECKER) #1

Expected behavior

Docker VM to start correctly

Actual behavior

Keep crashing and restarting in loop, even after a reset to factory defaults.

Information

pinata diagnose -u
OS X: version 10.11.4 (build: 15E65)
Docker.app: version v1.11.0-beta8.2
Running diagnostic tests:
Error docker ps: timeout after 10.00s
Thread 6 killed on uncaught exception Misc.Failure
Error docker ps: timeout after 10.00s
[ERROR] docker-cli docker ps failed: Misc.Failure
[OK] docker-cli
[OK] Moby booted
[OK] driver.amd64-linux
[OK] vmnetd
[OK] osxfs
[OK] db
[OK] slirp
[OK] menubar
[OK] environment
[OK] Docker
[OK] VT-x
Docker logs are being collected into /tmp/20160424-141845.tar.gz
Most specific failure is: docker ps failed: Misc.Failure
Your unique id is: 587D7BC7-C02D-4AA0-92FF-8B2CB7B479F2
Please quote this in all correspondence.

Steps to reproduce the behavior

  1. docker ps -a
    An error occurred trying to connect: Get http://%2Fvar%2Frun%2Fdocker.sock/v1.23/containers/json?all=1: EOF

  2. screen ~/Library/Containers/com.docker.docker/Data/com.docker.driver.amd64-linux/tty

  3. The TTY shows this :

Freeing initrd memory: 50176K (ffff880001d8d000 - ffff880004e8d000)
RAPL PMU detected, API unit is 2^-32 Joules, 3 fixed counters 163840 ms ovfl timer
hw unit of domain pp0-core 2^-16 Joules
hw unit of domain package 2^-16 Joules
hw unit of domain dram 2^-16 Joules
futex hash table entries: 2048 (order: 5, 131072 bytes)
HugeTLB registered 2 MB page size, pre-allocated 0 pages
fuse init (API version 7.23)
9p: Installing v9fs 9p2000 file system support
FS-Cache: Netfs ‘9p’ registered for caching
aufs 4.4-20160328
Key type big_key registered
NET: Registered protocol family 38
Block layer SCSI generic (bsg) driver version 0.4 loaded (major 251)
io scheduler noop registered
io scheduler deadline registered (default)
io scheduler cfq registered
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
pciehp: PCI Express Hot Plug Controller Driver version: 0.4
shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
input: Power Button as /devices/LNXSYSTM:00/LNXPWRBN:00/input/input0
ACPI: Power Button [PWRF]
GHES: HEST is not enabled!
virtio-pci 0000:00:02.0: virtio_pci: leaving for legacy driver
virtio-pci 0000:00:03.0: virtio_pci: leaving for legacy driver
virtio-pci 0000:00:04.0: virtio_pci: leaving for legacy driver
virtio-pci 0000:00:05.0: virtio_pci: leaving for legacy driver
virtio-pci 0000:00:06.0: virtio_pci: leaving for legacy driver
virtio-pci 0000:00:07.0: virtio_pci: leaving for legacy driver
virtio-pci 0000:00:08.0: virtio_pci: leaving for legacy driver
Serial: 8250/16550 driver, 4 ports, IRQ sharing disabled
00:01: ttyS0 at I/O 0x3f8 (irq = 4, base_baud = 115200) is a 16550A
00:02: ttyS1 at I/O 0x2f8 (irq = 3, base_baud = 115200) is a 16550A
Initializing Nozomi driver 2.1d
Non-volatile memory driver v1.3
Hangcheck: starting hangcheck timer 0.9.1 (tick is 180 seconds, margin is 60 seconds).
loop: module loaded
vda: vda1 vda2
hv_vmbus: registering driver hv_storvsc
Ethernet Channel Bonding Driver: v3.7.1 (April 27, 2011)
tun: Universal TUN/TAP device driver, 1.6
tun: © 1999-2004 Max Krasnyansky maxk@qualcomm.com
PPP generic driver version 2.4.2
hv_vmbus: registering driver hv_netvsc
hv_vmbus: registering driver hyperv_keyboard
mousedev: PS/2 mouse device common for all mice
input: PC Speaker as /devices/platform/pcspkr/input/input1
ACPI Error: Could not enable RealTimeClock event (20150930/evxfevnt-212)
ACPI Warning: Could not enable fixed event - RealTimeClock (4) (20150930/evxface-654)
rtc_cmos 00:03: rtc core: registered rtc_cmos as rtc0
rtc_cmos 00:03: alarms up to one day, y3k, 114 bytes nvram
i2c /dev entries driver
hv_utils: Registering HyperV Utility Driver
hv_vmbus: registering driver hv_util
hv_vmbus: registering driver hv_balloon
oprofile: using timer interrupt.
GACT probability on
Mirror/redirect action on
Simple TC action Loaded
netem: version 1.3
u32 classifier
Performance counters on
input device check on
Actions configured
Netfilter messages via NETLINK v0.30.
nfnl_acct: registering with nfnetlink.
nf_conntrack version 0.5.0 (16384 buckets, 65536 max)
ctnetlink v0.93: registering with nfnetlink.
nf_tables: © 2007-2009 Patrick McHardy kaber@trash.net
nf_tables_compat: © 2012 Pablo Neira Ayuso pablo@netfilter.org
xt_time: kernel timezone is -0000
ip_set: protocol 6
IPVS: Registered protocols ()
IPVS: Connection hash table configured (size=4096, memory=64Kbytes)
IPVS: Creating netns size=1328 id=0
IPVS: ipvs loaded.
gre: GRE over IPv4 demultiplexor driver
ip_tables: © 2000-2006 Netfilter Core Team
ipt_CLUSTERIP: ClusterIP Version 0.8 loaded successfully
arp_tables: © 2002 David S. Miller
Initializing XFRM netlink socket
NET: Registered protocol family 10
mip6: Mobile IPv6
ip6_tables: © 2000-2006 Netfilter Core Team
sit: IPv6 over IPv4 tunneling driver
ip6_gre: GRE over IPv6 tunneling driver
NET: Registered protocol family 17
NET: Registered protocol family 15
bridge: automatic filtering via arp/ip/ip6tables has been deprecated. Update your scripts to load br_netfilter if you need this.
Bridge firewalling registered
Ebtables v2.0 registered
l2tp_core: L2TP core driver, V2.0
8021q: 802.1Q VLAN Support v1.8
9pnet: Installing 9P2000 support
Key type dns_resolver registered
openvswitch: Open vSwitch switching datapath
NET: Registered protocol family 40
hv_sock: failed to load: VMBus 4 or later is required
mpls_gso: MPLS GSO support
microcode: CPU0 sig=0x306e4, pf=0x1, revision=0x0
microcode: CPU1 sig=0x306e4, pf=0x1, revision=0x0
microcode: CPU2 sig=0x306e4, pf=0x1, revision=0x0
microcode: CPU3 sig=0x306e4, pf=0x1, revision=0x0
microcode: CPU4 sig=0x306e4, pf=0x1, revision=0x0
microcode: CPU5 sig=0x306e4, pf=0x1, revision=0x0
microcode: CPU6 sig=0x306e4, pf=0x1, revision=0x0
microcode: CPU7 sig=0x306e4, pf=0x1, revision=0x0
microcode: Microcode Update Driver: v2.01 tigran@aivazian.fsnet.co.uk, Peter Oruba
AVX version of gcm_enc/dec engaged.
AES CTR mode by8 optimization enabled
registered taskstats version 1
Key type encrypted registered
rtc_cmos 00:03: setting system clock to 2016-04-24 12:19:55 UTC (1461500395)
Freeing unused kernel memory: 920K (ffffffff8186d000 - ffffffff81953000)

OpenRC 0.19.368c2a1 is starting up Linux 4.4.6 (x86_64)

  • Mounting /proc … [ ok ]
  • Mounting /run … * /run/openrc: creating directory
  • /run/lock: creating directory
  • /run/lock: correcting owner
  • Caching service dependencies … [ ok ]
  • Configuring binfmt misc … [ ok ]
  • Mounting tmpfs on /dev … [ ok ]
  • Mounting /dev/mqueue … [ ok ]
  • Mounting /dev/pts … [ ok ]
  • Mounting /dev/shm … [ ok ]
  • Mounting /sys … [ ok ]
  • Mounting security filesystem … [ ok ]
  • Mounting debug filesystem … [ ok ]
  • Mounting fuse control filesystem … [ ok ]
  • Mounting cgroup filesystem … [ ok ]
  • Starting busybox mdev … [ ok ]
  • Loading hardware drivers … [ ok ]
  • Checking local filesystems … [ ok ]
  • Setting system clock using the hardware clock [UTC] … [ ok ]
  • Setting hostname … [ ok ]
  • Remounting filesystems … [ ok ]
  • Mounting local filesystems … [ ok ]
  • Starting busybox klogd … [ ok ]
  • Configuring host block device … [ ok ]
  • Activating swap devices … [ ok ]
  • Configuring host settings from database … [ ok ]
  • Configuring kernel parameters … [ ok ]
  • Creating user login records … [ ok ]
  • Wiping /tmp directory … [ ok ]
  • Starting busybox klogd … [ ok ]
  • Starting networking … * lo … [ ok ]
  • eth0 …udhcpc failed to get a DHCP lease
    [ !! ]
  • eth1 … [ ok ]
  • Testing DNS resolution … [ ok ]
  • Starting busybox syslog … [ ok ]
  • Initializing random number generator … [ ok ]
  • Starting busybox acpid … [ ok ]
  • Starting FUSE socket passthrough … [ ok ]
  • Setting up proxy port mount … [ ok ]
  • Starting docker socket vsock passthrough … [ ok ]
  • Starting Docker …mount: special device /Mac/Users/arnobeck/Library/Containers/com.docker.docker/Data/com.docker.driver.amd64-linux/log does not exist
    [ ok ]
  • Starting chronyd … [ ok ]
  • Starting busybox cron … [ ok ]
  • Starting mDNS server … [ ok ]
  • Starting docker config update manager … [ ok ]
  • Checking system state …
    ✓ Drive found: vda
    ✓ Drive mounted: /dev/vda2 on /var type ext4 (rw,relatime,data=ordered)
    ✗ No network connection
    ✗ No transfused process
    ✓ Process mdnstool running: /sbin/mdnstool -if eth0 -hostname docker.local.
    ✓ Process hupper running: /bin/hupper -pidfile /run/hupper.pid -huppidfile /run/docker.pid -path /Database/branch/master/watch/com.docker.driver.amd64-linux.node/etc.node/docker.node/daemon.json.node/tree.live
    ✗ No docker process
    ✓ Process containerd running: docker-containerd -l /var/run/docker/libcontainerd/docker-containerd.sock --runtime docker-runc --debug --metrics-interval=0
    ✗ Docker ps failed: Cannot connect to the Docker daemon. Is the docker daemon running on this host?
    ✓ Diagnostics server running: /usr/bin/diagnostics-server
  • Saving random seed … [ ok ]
  • Stopping docker config update manager … [ ok ]
  • Stopping mDNS server … [ ok ]
  • Stopping busybox cron … [ ok ]
  • Stopping busybox syslog … [ ok ]
  • Stopping chronyd … [ ok ]
  • Stopping docker
  • Unmounting loop devices
  • Unmounting filesystems
  • Unmounting /port … [ ok ]
  • Unmounting /Database … [ ok ]
  • Unmounting /var … * in use but fuser finds nothing
    [ !! ]
    reboot: Power down