Docker volume store data in ceph storage

I need some help on the integration docker volume with ceph storage using cephfs… I tried that with kernel driver in VM /etc/fstab …but the query is how do I know whether data stores or not

I don’t understand the question. Please, explain in more details what is your use case and what you would like to do.

If your question is related to Ceph specifically, I don’t think a Docker forum is the best place to ask.

I have a few bind mounts like below —

… etc

now I am planning to integrate those mounts with Ceph storage using Cephfs like inside /etc/fstab —

[{ipaddress}:{port}]:confused: {mount}/{mountpoint} ceph [name=username,secret=secretkey|secretfile=/path/to/secretfile],[{mount.options}]

after that, I ran: mount -a

then when I ran the df -Th command I was able to see those mappings, but how do I know if those mounts actually store data in Ceph or not …

We don’t know anything about the context, and the shared details are too ambiguous to guess anything.
First we need to be able to understand the objective, and what the challenge is.

  • How is all of this related to docker?
  • Where is the command mount -a executed? On the host? Inside a container?
  • Do you intend to mount ceph on the host and then bind the mounted folder into a container?
  • Or do you intend to use a volume plugin to mount ceph as named volume? Have you googled if such a volume plugin exists?
1 Like