Docker Community Forums

Share and learn in the Docker community.

Docker with Juniper VPN

docker

(Hans Kramer) #1

Dear Docker community,

I hope I post this in the right forum. Anyway, my problem is that straightforward:
I need to run docker with Juniper VPN to connect to resources at my work.

Once I have started the vpn client, the docker container does not see the network anymore.
I have tried to restart the docker engine after I established the VPN connection, but still no dice. Still network is unreachable…

I looked briefly at the network options: --default-gateway, -b BRIDGE, etc However, I am not network savvy enought to troubleshoot this.

On the host, when I run route I see this
[hans@eng-hkramer ~]$ route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
0.0.0.0 10.10.15.20 0.0.0.0 UG 1 0 0 tun0
0.0.0.0 10.0.0.1 0.0.0.0 UG 1024 0 0 wlp3s0
10.0.0.0 10.10.15.20 255.255.255.0 UG 1 0 0 tun0
10.0.0.0 0.0.0.0 255.255.255.0 U 10 0 0 wlp3s0
10.0.0.1 0.0.0.0 255.255.255.255 UH 1 0 0 wlp3s0
64.41.144.204 10.0.0.1 255.255.255.255 UGH 1 0 0 wlp3s0
172.17.0.0 10.10.15.20 255.255.0.0 UG 1 0 0 tun0
172.17.0.0 0.0.0.0 255.255.0.0 U 10 0 0 docker0

I am rather puzzled about the two default gateways… so I figured I need to specify --default-gateway=10.10.15.20
… that didn’t fly.

So please, help is appreciated!

Thanks

Hans