Does docker-compose support --context flag or anything for remote calls?

Based on this article How to deploy on remote Docker hosts with docker-compose - Docker Blog I should be able to either user docker-compose with the --context flag or -H or DOCKER_HOST env.

At this time I do not think any of this works.

Current versions

me:api$ docker-compose  -v
docker-compose version 1.29.2, build unknown
me:api$ docker -v
Docker version 20.10.7, build 20.10.7-0ubuntu5~20.04.2

I created the context like

docker context create prod --docker "host=ssh://user@host.com"

And can run docker --context prod ps

With docker-compose though

docker-compose --context prod -f docker-compose.yml -f docker-compose.prod.yml up -d
ERROR: Context 'prod' not found

This has been outlined here Context not found when given on docker-compose CLI · Issue #7434 · docker/compose · GitHub but for 2 year appears to have been ignored.

I tried the -H flag too

docker-compose -H ssh://user@host -f docker-compose.yml -f docker-compose.prod.yml up -d
/bin/sh: 1: ssh: Permission denied

It is the same result with the DOCKER_HOST env

DOCKER_HOST=ssh://me@host docker-compose ps
/bin/sh: 1: ssh: Permission denied

AND YES I CAN 100% ssh as the user I have in all the situations.

Even better is that the new an improved docker compose drop in replacement does not even recognize the flag.

docker compose --context prod ps
unknown flag: --context

Is there something I am missing or does docker-compose not work?