Docker Community Forums

Share and learn in the Docker community.

Does Official Adminer Container Support MySQL 5.7?

I have deployed a VMWare Photon 3.0 VM with Adminer:latest and MySQL:5.6, and everything has worked fine. I’m now exploring spinning up a new VM with MySQL:5.7 and Adminer (:latest) tells me “SQLSTATE[HY000] [2002] php_network_getaddresses: getaddrinfo failed: Name does not resolve”. I’m going to troubleshoot this, of course, but I wonder if anyone else has tried and/or had any success or knows that the current official Adminer Docker container does not support MySQL 5.7? Thanks in advance.

Okay, I figured out that yes, it appears to work just fine, if you don’t get all controlfreak with your hosts files. In my case I was passing the /etc/hostname and /etc/hosts files to the container (I thought I could just set this to be modifiable in one place but it appears that each container needs to manage its hostname and hosts separately). Hope that’s helpful to someone in the future!