Docker Community Forums

Share and learn in the Docker community.

Downgrade to Docker for Mac beta 11

(Michaël Perrin) #1


I just ugpraded to Docker for Mac beta 12, and it seems I am experiencing issues with folder permissions on a Symfony app.

I would like to make sure this is due to the upgrade, but I can’t find the previous beta download link.

Could someone provide the download link for Beta 11?



(MB) #2

Since the upgrade I’m also getting a lot of errors with file operations on shared volumes.
Many of them seem random, but I consistently get this one when running an rm -fr:

# rm -fr Packages
rm: cannot remove 'Packages/Dir001': Directory not empty

I’d really like to downgrade to beta 11 to

  1. check if the rm issue occurs (it shouldn’t since it wasn’t)
  2. check if the other random errors still occur
  3. Keep working

(Michaël Perrin) #3

I get exactly the same kind of issues on shared volumes.

rm -rf doesn’t allow me to remove directories, telling me exactly the same error (I thought it was me, almost ashamed :blush:):

rm: cannot remove 'my_dir_in_shared_volume': Directory not empty.

For now the only solution was to move my shared directory to a non-shared one.
This is definitely a beta12 issue then.

(Dave Tucker) #4

I can’t seem to reproduce the issue…

$ mkdir -p foo/bar
$ touch foo/bar/a
$ touch foo/bar/b
$ touch foo/bar/c
$ docker run docker run -v `pwd`:/mnt -it alpine /bin/sh
/ # rm -rf /mnt/foo/bar
/ # 

Can you please provide steps to reproduce?

(Michaël Perrin) #5

Same for me, it doesn’t happen if I create dirs & files myself and try to remove them.

It happens with cache files Symfony creates with the command line. I’ll have to investigate to give a way to reproduce this issue without Symfony.

(Dave Tucker) #6

Looks like I can repro using npm as mentioned in another thread. I’ve opened bug (#3229) on our tracker.
We’ll have a fix for this soon…

(MB) #7

Thanks for the feedback! In the meantime, is there a way to revert to beta11?

(Michaël Perrin) #8

Thanks @davetucker. In the meanwhile if would have a link to Docker for Mac beta 11, that would be welcome!

Beta13 volume bind mounts intermittently error on access with 'bad file descriptor'
(MB) #9

I finally found it in my ~/Trash folder, thanks OSX!
In case it can be useful, I’ve uploaded it here:

I stopped my beta12 instance, then did a normal install of the beta11, and everything seems to work fine.

(Michaël Perrin) #10

Great! I reverted to beta 11 thanks to your link.
I found back beta 10 on an other computer, but beta 11 is the most up-to-date working version.

(Bradley Broom) #11

I also encountered this. Reverting to beta 11 appears to have fixed it.

(Thomas Dutrion) #12

I experienced some problems as well today. Using “Settings” > “Uninstall / Reset” > “Reset to factory defaults” seems to fix it.

As I am also working on a symfony app (dev), I am now experiencing another error: date on the mac and in the container are different, which makes symfony fail the tests and refresh the cache at each request. Still investigating solutions for that.

(Vinayh) #13

Thank you man! You saved me. beta13 screwed things up for me. :stuck_out_tongue:

(Michaël Perrin) #14

Ouch, the problem hasn’t been fixed in beta 13 then? I’m going to keep beta 11 then, despite the performance improvements announced for beta 13.

(Michaël Perrin) #15

Resetting factory defaults didn’t work for me.

(Vinayh) #16

Should have added a little more context. I’m experiencing this issue, which was new to me as of 13:

(Jimmy Cuadra) #17

Could a Docker employee please provide an official image for beta 11? A Google Drive link from a forum user is not an acceptable way to install.

(Michaël Perrin) #18

It seems like I had the problem again with the latest beta.

I downgraded to RC4-beta20 and things are working again.