Docker Community Forums

Share and learn in the Docker community.

Error during docker pull

Hello, i want to install nextloud into docker on OMV5 with the guidance of TechnoDadLife (https://www.youtube.com/watch?v=T_2csDJFa2k) on my Raspberry Pi 4.

When i run docker it seems like that i got a problem during the pull.
docker run -d -p 4443:4443 -p 443:443 -p 80:80 -v /srv/dev-disk-by-label-Backup/appdata/ncdata:/data --name nextcloudpi ownyourbits/nextcloudpi-armhf 192.168.178.77

Does anybody know of you what happens?

This information i got with “docker info”

Client:
Debug Mode: false

Server:
Containers: 3
Running: 1
Paused: 0
Stopped: 2
Images: 2
Server Version: 19.03.12
Storage Driver: overlay2
Backing Filesystem: extfs
Supports d_type: true
Native Overlay Diff: true
Logging Driver: json-file
Cgroup Driver: cgroupfs
Plugins:
Volume: local
Network: bridge host ipvlan macvlan null overlay
Log: awslogs fluentd gcplogs gelf journald json-file local logentries splunk syslog
Swarm: inactive
Runtimes: runc
Default Runtime: runc
Init Binary: docker-init
containerd version: 7ad184331fa3e55e52b890ea95e65ba581ae3429
runc version: dc9208a3303feef5b3839f4323d9beb36df0a9dd
init version: fec3683
Security Options:
seccomp
Profile: default
Kernel Version: 4.19.118-v7l+
Operating System: Raspbian GNU/Linux 10 (buster)
OSType: linux
Architecture: armv7l
CPUs: 4
Total Memory: 3.814GiB
Name: raspberrypi
ID: LRWZ:OAXI:5TH6:6Q52:7ASZ:XQPX:6F3V:56R5:2DLC:VGGC:PINK:SBUA
Docker Root Dir: /srv/dev-disk-by-label-Backup/docker
Debug Mode: false
Registry: https://index.docker.io/v1/
Labels:
Experimental: false
Insecure Registries:
127.0.0.0/8
Live Restore Enabled: false

You need some more informations?

Thanks for you help.

I am have a very similar/same issue, something new in the last couple of months …

My installation is a Raspberry Pi 3B+ with OMV 5 installed. I’ve built a new image on a SD card earlier today to eliminate any possible issues with the old/3 month install - no change.

I was successful with a Portainer and a Mosquitto docker install. But the PI will freeze mid way through the image pull and expansion process without warning or error messages when I pull images for Domoticz and PiHole. And the process appears to stop at the same point on repeated attempts. For example, the Pi freezes at this point repeatedly during a pihole pull request “aa8766521825: Extracting 77.43MB/109.8MB”

None of the log files offer any insight, no indication of low voltage,

Further details follow:

pi@raspberrypi:~ $ sudo docker pull pihole/pihole
Using default tag: latest
latest: Pulling from pihole/pihole
e01632f4dd89: Already exists
0657b8650289: Already exists
98e54fa01738: Already exists
aa8766521825: Extracting 77.43MB/109.8MB
958cb6229ddd: Download complete
2365ef735c5e: Download complete
6340fddb18c0: Download complete
c4eeb5527eac: Download complete

pi@raspberrypi:~ $ cat /etc/os-release
PRETTY_NAME=“Raspbian GNU/Linux 10 (buster)”
NAME=“Raspbian GNU/Linux”
VERSION_ID=“10”
VERSION=“10 (buster)”
VERSION_CODENAME=buster
ID=raspbian

pi@raspberrypi:~ $ cat /proc/cpuinfo
processor : 0
model name : ARMv7 Processor rev 4 (v7l)
BogoMIPS : 38.40
Features : half thumb fastmult vfp edsp neon vfpv3 tls vfpv4 idiva idivt vfpd32 lpae evtstrm crc32
CPU implementer : 0x41
CPU architecture: 7
CPU variant : 0x0
CPU part : 0xd03
CPU revision : 4

processor : 1
model name : ARMv7 Processor rev 4 (v7l)
BogoMIPS : 38.40
Features : half thumb fastmult vfp edsp neon vfpv3 tls vfpv4 idiva idivt vfpd32 lpae evtstrm crc32
CPU implementer : 0x41
CPU architecture: 7
CPU variant : 0x0
CPU part : 0xd03
CPU revision : 4

processor : 2
model name : ARMv7 Processor rev 4 (v7l)
BogoMIPS : 38.40
Features : half thumb fastmult vfp edsp neon vfpv3 tls vfpv4 idiva idivt vfpd32 lpae evtstrm crc32
CPU implementer : 0x41
CPU architecture: 7
CPU variant : 0x0
CPU part : 0xd03
CPU revision : 4

processor : 3
model name : ARMv7 Processor rev 4 (v7l)
BogoMIPS : 38.40
Features : half thumb fastmult vfp edsp neon vfpv3 tls vfpv4 idiva idivt vfpd32 lpae evtstrm crc32
CPU implementer : 0x41
CPU architecture: 7
CPU variant : 0x0
CPU part : 0xd03
CPU revision : 4

Hardware : BCM2835
Revision : a020d3
Serial : 00000000870f7283
Model : Raspberry Pi 3 Model B Plus Rev 1.3

pi@raspberrypi:~ $ sudo docker version
Client: Docker Engine - Community
Version: 19.03.12
API version: 1.40
Go version: go1.13.10
Git commit: 48a6621
Built: Mon Jun 22 15:57:03 2020
OS/Arch: linux/arm
Experimental: false

Server: Docker Engine - Community
Engine:
Version: 19.03.12
API version: 1.40 (minimum version 1.12)
Go version: go1.13.10
Git commit: 48a6621
Built: Mon Jun 22 15:50:36 2020
OS/Arch: linux/arm
Experimental: false
containerd:
Version: 1.2.13
GitCommit: 7ad184331fa3e55e52b890ea95e65ba581ae3429
runc:
Version: 1.0.0-rc10
GitCommit: dc9208a3303feef5b3839f4323d9beb36df0a9dd
docker-init:
Version: 0.18.0
GitCommit: fec3683

================================================================================
= openmediavault information

Release: 5.5.3-1
Codename: Usul

Any suggestions on how to resolve?

Thanks,