Docker Community Forums

Share and learn in the Docker community.

Error "libtinfo.so.5: cannot change memory protections"

docker

#1

I am having this error while trying to run any container in my computer:

/bin/bash: error while loading shared libraries: libtinfo.so.5: cannot change memory protections

The problem started after I changed my docker base directory following the instructions in this post: How do I change the Docker image installation directory?

I have a machine running Fedora 29 with two drivers. My first drive is a SSD mounted at /. The second drive is a standard HDD, mounted at /home. Originally, my the base docker base directory was the default /lib/var/docker. Everything worked normally, but since my SSD is small, I tried to move the base directory to /home/docker-files.
This is the content of my daemon.json file:

{
    "graph": "/home/docker-files"
}

If I erase the graph and restart docker process, everything works fine again. The problem only happens when I set to the secondary drive.
I made some searches, but was not able to find similar situations. Does anybody knows what is going on?
I am open to different approaches to move the base directory to the secondary drive.