Error loading image

I have an image I created on Linux with docker 1.7.1. I am trying to load that to docker version 17.03.2-ee-5 running on windows. Is that something that I should expect to work. It failed with this error:

re-exec error: exit status 1: output: Failed to OpenForBackup failed in Win32: open \?\C:\ProgramData\docker\windowsfilter\6c1f9bde45712c6a54a33ed6dc7f208d45c06bd6ab5af7401dd935e448c460e6\usr\share\man\man7\pam.7.gz: The file exists. (0x1f) \?\C:\ProgramData\docker\windowsfilter\6c1f9bde45712c6a54a33ed6dc7f208d45c06bd6ab5af7401dd935e448c460e6\usr\share\man\man7\pam.7.gz

I just tried to build the image directly on windows and I get “image operating system “linux” cannot be used on this platform” I guess I have grossly misunderstood exactly what docker is. I thought it would allow me to move images from one system to another regardless of the underlying OS. It seems that is not the case.

With containers the OS kernel (not the hardware) is virtualized. To run Docker Windows containers, you need a Windows system and vice-versa for Linux. Details here:

We do, however, make available Docker for Windows which lets you run build and test Docker Linux containers on Windows for development (but not production). Microsoft is also in the process of adding Linux container support into Windows directly:

What do you mean by ’ lets you run build and test Docker Linux containers on Windows for development (but not production)?’ What would prevent me running it in production?

It’s not a design use case and the Docker for Windows app is not build to run headless. Also no support.

I installed Docker for Windows but every docker command I try give me:

error during connect: Post http://%2F%2F.%2Fpipe%2Fdocker_engine/v1.30/images/load?quiet=0: open //./pipe/docker_engine:
The system cannot find the file specified. In the default daemon configuration on Windows, the docker client must be run elevated to connect. This error may also indicate that the docker daemon is not running.

I am running in an admin shell. How do I run the docker daemon?

I found this post:

I tried Restart-Service docker still got the same error. Note that the GUI will not run.