Docker Community Forums

Share and learn in the Docker community.

Error read-only file system : write /var/lib/docker/buildkit/metadata_v2.db

Hello,

I start a new topic because I haven’t seen an issue like it or I don’t get the solutions given. I’m new on Docker, I try to execute a code from the deepfake detection challenge and implement an environment on Docker from a Dockerfile.

I send this command : docker build -t dfdc .
It ran for hours and suddenly stops and return this :
error committing oijjxknimo4fk7527zrk8un56: write /var/lib/docker/buildkit/metadata_v2.db: read-only file system

The same error appears the last time but it was after only an hour running:
error committing zby0lsn87ttxmpdq9wa9sggmr: write /var/lib/docker/buildkit/metadata_v2.db: read-only file system

I don’t get why it hasn’t stop at the same moment.
I tried to rerun just after and I got this:
ERROR [internal] load .dockerignore
ERROR [internal] load build definition from Dockerfile
failed to solve with frontend dockerfile.v0: failed to read dockerfile: failed to create lease: write /var/lib/docker/buildkit/containerdmeta.db: read-only file system

Does someone can help me ? Any ideas ?

Thank you for your time and your help,

Soizic

I recently got this error and almost same to yours.
Seems like my drive has no enough space for my wsl system and I fixed it by cleaning up.

2 Likes

I had the issue) It helps!