Error response from daemon: open \\.\pipe\docker_engine_windows: The system cannot find the file specified

I’m a new user and don’t know enough to troubleshoot efficiently. (New as in, I just went through the getting-started demo this morning.) After I switched to windows I can’t get anywhere. I’ve been to many forums and tried many things, it’s not working at all.

PS C:\temp> docker config ls
Error response from daemon: open \\.\pipe\docker_engine_windows: The system cannot find the file specified.

Docker Desktop 4.14.1
|Edition|Windows 11 Enterprise|
|Version|22H2|
|OS build|22621.674|

Listing out the named pipes, there is none called docker_engine_windows. I do see one called docker_engine though. Bug in the installer?

Should I change it to docker_engine? Is this path configurable?

PS C:\temp> [System.IO.Directory]::GetFiles("\\.\pipe\") | sort
\\.\pipe\{641B073C-E4A8-4FC1-82CE-CEE579CD0BE6}
\\.\pipe\{C6A9690C-33AE-4a55-8B65-9498CC0A7B34}.OnScreenDisplay
\\.\pipe\{C6A9690C-33AE-4a55-8B65-9498CC0A7B34}.ShortcutKey
\\.\pipe\{CDB19379-7200-4889-9B2B-B66C1CC8A119}
\\.\pipe\5EA58BF9-13F1-4F04-A152-CB928468DFFC
\\.\pipe\7cd778a4-63c1-454a-a0cd-5c8abcc58ad4
\\.\pipe\atsvc
\\.\pipe\bVtbdjU68TwcURnOw7IjAlQMjz7ACVZ0hgArV3TDhzvM2oJWrN9BsLU1E7ttWznTDHyZJ72KRGxYhbZvkvfTFnDNrIOFJh6qkeXkmHgxfGc0Y5jWqOuVHE
\\.\pipe\crashpad_9172_NCELFARXIOWIJVWC
\\.\pipe\Ctx_WinStation_API_service
\\.\pipe\CxUIUSvcChannel
\\.\pipe\docker_cli
\\.\pipe\docker_engine
\\.\pipe\dockerAPIProxyControl
\\.\pipe\dockerBackendApiServer
\\.\pipe\dockerBackendNativeApiServer
\\.\pipe\dockerBackendV2
\\.\pipe\dockerDesktopEngine
\\.\pipe\dockerDesktopLinuxEngine
\\.\pipe\dockerDesktopWindowsEngine
\\.\pipe\dockerDevEnvApiServer
\\.\pipe\dockerDNSInternalGRPC
\\.\pipe\dockerDNSSystemGRPC
\\.\pipe\dockerExport
\\.\pipe\dockerExtensionManagerAPI
\\.\pipe\dockerFilesystem
\\.\pipe\dockerHTTPProxy
\\.\pipe\dockerHubProxy
\\.\pipe\dockerNetworkProxy
\\.\pipe\dockerNTPUDP
\\.\pipe\dockerSOCKS
\\.\pipe\dockerVolume
\\.\pipe\dockerVpnKitControl
\\.\pipe\dockerVpnkitData
\\.\pipe\dotnet-diagnostic-21452
\\.\pipe\dotnet-diagnostic-6328
\\.\pipe\dotnet-diagnostic-8220
\\.\pipe\ecc447d0-6aa9-47e0-9385-ccd29e367134
...
1 Like

Reinstalling with the “Use WSL 2 instead of Hyper-V (recommended)” box unchecked fixed the issue. (Reinstalling probably wasn’t necessary because WSL is a config option in the general settings.)

I don’t know what that has to do with a named pipe. Anyway, without understanding the problem, I pushed buttons until I got past it.

PS C:\temp> [System.IO.Directory]::GetFiles("\\.\pipe\") | Select-String docker_engine

\\.\pipe\docker_engine
\\.\pipe\docker_engine_linux

PS C:\temp> pushd 'C:\Program Files\Docker\Docker\'; .\DockerCli.exe -SwitchDaemon; popd
PS C:\temp> [System.IO.Directory]::GetFiles("\\.\pipe\") | Select-String docker_engine

\\.\pipe\docker_engine_linux
\\.\pipe\docker_engine
\\.\pipe\docker_engine_windows

I am trying to build a windows based container and i get the same error. It seems to be an issue with latest release, i have installed 10/31 release and it works fine. For some reason docker engine is not showing up in the windows services with the latest release. After trying multiple things , i finally gave up and installed 10/31 release and everything works. hope this helps someone

1 Like

Same here - pulling an Windows image from a registry ends up in:
Error response from daemon: open \\.\pipe\docker_engine_windows: The system cannot find the file specified.

Same here. I restarted the docker desktop multiple times, and tried to switch between windows and Linux containers, and it is not switching as well.

Have started seeing same issue for Windows containers after upgrading to v4.14.1 (91661). Is there a problem with this new version?

I had the same issue, I took chedebala’s advice, uninstalled 4.14.1 and downloaded 4.13.0 and that worked for me

here is a link for anyone who needs help downloading an older version
4.13.0

https://desktop.docker.com/win/main/amd64/89412/Docker%20Desktop%20Installer.exe

download link

4.13.1 was released on oct31, so that might work too but i’m running 4.13.0. here is the link if you want to try

https://desktop.docker.com/win/main/amd64/90346/Docker%20Desktop%20Installer.exe

( i’m a noob so I can’t put more than 2 links )

I got the urls from chocolatey
Chocolatey Software | Docker Desktop 4.13.0

Try add Optional Feature - Container and Hyper-V to windows.
In Windows 11:
Apps → Optional features → More Windows features → Check Containers and Hyper-V and click OK

or try run:
Enable-WindowsOptionalFeature -Online -FeatureName containers –All
Enable-WindowsOptionalFeature -Online -FeatureName Microsoft-Hyper-V –All

If still not working uninstall Docker Desktop and install Docker Desktop 4.13.1 from here:

more info here:

1 Like