Docker Community Forums

Share and learn in the Docker community.

Error running docker immediately after installing docker for Mac


(Zeddicus76) #1

Expected behavior

I expected normal docker response.

Actual behavior

$ docker ps
Error response from daemon: dial unix /Users/Gavin/Library/Containers/com.docker.docker/Data/*00000003.00000948: connect: no such file or directory

sudo didn’t work either, it gave me the same error.
$ sudo docker ps
Error response from daemon: dial unix /Users/Gavin/Library/Containers/com.docker.docker/Data/*00000003.00000948: connect: no such file or directory

Information

  • the output of:
    • pinata diagnose -u on OSX
    • DockerDebugInfo.ps1 using Powershell on Windows
  • a reproducible case if this is a bug, Dockerfiles FTW
  • page URL if this is a docs issue or the name of a man page
  • host distribution and version ( OSX 10.10.x, OSX 10.11.x, Windows, etc )

$ pinata diagnose -u
OS X: version 10.11.5 (build: 15F34)
Docker.app: version v1.11.1-beta13
Running diagnostic tests:
[ERROR] Moby booted /Users/Gavin/Library/Containers/com.docker.docker/Data/com.docker.driver.amd64-linux/console-ring does not exist
[OK] Moby booted
[OK] driver.amd64-linux
[OK] vmnetd
[OK] osxfs
[OK] db
[OK] slirp
[OK] menubar
[OK] environment
[OK] Docker
[OK] VT-x
Docker logs are being collected into /tmp/20160526-190146.tar.gz
Most specific failure is: /Users/Gavin/Library/Containers/com.docker.docker/Data/com.docker.driver.amd64-linux/console-ring does not exist

Steps to reproduce the behavior

  1. Immediately after installing docker for Mac I tried the docker command and got the error.
  2. After rebooting (based on one other issue I found) the same error is showing up when I try a docker command.

(Zeddicus76) #2

I uninstalled docker (which says it failed) then re-installed it and now it appears to be working.


(jewer) #3

I have same issue, but it had happened when i worked into container

Error response from daemon: dial unix /Users/xjewer/Library/Containers/com.docker.docker/Data/*00000003.00000948: connect: connection refused

Diagnostic ID: 8946FD4A-627A-45EA-9943-343D123D5A77


(Davechains) #4

Hi All, I have a Hackintosh and when i install docker for mac on the terminal throw me this Error when I was trying a Docker ps, I discover on my Bios virtual vtx that allow the processor (A I7 4790k in this case) have virtualization ! I enable this feature and it works!
Any Concern Let me know!


(Tleung999) #5

Just adding to this post. I can also confirm turning on virtualization in the BIOS fixes this.