Error trying to mount CIFS network share

I am using docker for the first time. I have docker desktop on a windows 10 system.
When trying to install PhotoPrism following this guide I ran into a problem at the network share step. I have a NAS on which I would like my storage folder to be located. I thus followed the instructions PhotoPrism provides and ended up with this in my yaml file:

      - "originals:/photoprism/originals"
    driver: local
      type: cifs
      o: "username=photoprism, password=<mypassword>"
      device: "//"

When running docker compose, I get this error message:

Error response from daemon: failed to mount local volume: mount //, data: username=photoprism,password=********: host is down

The strange thing is that the host isn’t down: I can access it from the same machine using the same credentials just fine. I have searched the internet but did not find any useful information.
Thanks to everyone for your support

Have you tried defining the address?

o: "username=photoprism, password=<mypassword>, addr="