Error when buildng deployment with dockercompose using images for Widhfly and Mysql

I’m using dockercompose to deploy an application developped with JSF primefaces, Mysql 8.0, Hibernate 5.6.8.
The application is composed of two parts:

-The front End application developped using **JSF primefaces 11.0,** **Mysql connector 8.0.13** and **hibernate 8.0.13.**
-The Database part developped with **Mysql 8.0**

Below the list of files used to deploy the docker images:

docker-compose.yml

version: “3.7”
services:
api_service:
image: Quay
build:
context: .
dockerfile: DockerfileJDK
restart: always
ports:
- 8080:8080
environment:
MYSQL_USER: root
MYSQL_PASSWORD: mypassword
MYSQL_DATABASE: manage_department
MYSQL_HOST: mysql_db
depends_on:
- mysql_db
mysql_db:
image: mysql:8.0
container_name: mysql-standlone
volumes:
- ./dockerfolder/backend/manage_department.sql
restart: always
ports:
- 3306:3306
environment:
- MYSQL_ROOT_PASSWORD=mypassword
- MYSQL_DATABASE=manage_department

DockerfileJDK:

FROM Quay
COPY ./dockerfolder/backend/JSF-Manage-Department.war /opt/jboss/wildfly/standalone/deployments/
RUN /opt/jboss/wildfly/bin/add-user.sh admin Admin#70365 --silent
CMD [“/opt/jboss/wildfly/bin/standalone.sh”, “-b”, “0.0.0.0”, “-bmanagement”, “0.0.0.0”]
EXPOSE 8080

When trying to build different images using sudo docker-compose up --build, the below error is generated :

api_service_1 | 12:11:21,179 INFO [org.jboss.weld.Bootstrap] (Weld Thread Pool – 7) WELD-000119: Not generating any bean definitions from jsf-manage.department.dao.AppSettingDAOImpl because of underlying class loading error: Type SessionFactory from [Module “JSF-Manage-Department.war” from Service Module Loader] not found. If this is unexpected, enable DEBUG logging to see the full error.

It is possible that the error is related to then connection to the database that’s why the managed beans could not be generated as described in the following error message.

Does some one know about this error ?
Thanks