Docker Community Forums

Share and learn in the Docker community.

Error when trying to start a container


(Racemd) #1

Hello, I am new to Docker, wanted to do a install and test/play. I did a base install of Docker-EE on RHEL 7, configured a test container with a simple port 80 web page/index.html. I get the following error when I try to start the container
standard_init_linux.go:187: exec user process caused “operation not permitted”
How can I get more information to tell me why the “operation is not permitted”?
I tried starting docker with “dockerd -D” and also tried the container start with “docker -D c9j” but did not get any additional valuable information.

Containers: 3
Running: 1
Paused: 0
Stopped: 2
Images: 2
Server Version: 17.06.1-ee-2
Storage Driver: overlay
Backing Filesystem: xfs
Supports d_type: false
Logging Driver: json-file
Cgroup Driver: cgroupfs
Plugins:
Volume: local
Network: bridge host macvlan null overlay
Log: awslogs fluentd gcplogs gelf journald json-file logentries splunk syslog
Swarm: inactive
Runtimes: runc
Default Runtime: runc
Init Binary: docker-init
containerd version: 6e23458c129b551d5c9871e5174f6b1b7f6d1170
runc version: 810190ceaa507aa2727d7ae6f4790c76ec150bd2
init version: 949e6fa
Security Options:
seccomp
Profile: default
Kernel Version: 3.10.0-514.2.2.el7.x86_64
Operating System: Red Hat Enterprise Linux Server 7.3 (Maipo)
OSType: linux
Architecture: x86_64
CPUs: 2
Total Memory: 11.58GiB
Name: a0002v1r0000125
ID: 454R:OG7Z:DP5G:IM3Y:KYP4:VGST:ZKDL:OXE2:45RV:YYK6:2L77:YHRV
Docker Root Dir: /var/lib/docker
Debug Mode (client): false
Debug Mode (server): false
Registry: https://index.docker.io/v1/
Experimental: false
Insecure Registries:
127.0.0.0/8
Live Restore Enabled: false