Error while installing Docker Desktop

Hi there!

Can someone please provide assistance over here? I’m trying to install DOCKER DESKTOP on my mac but receiving error below -

‘getting startup settings: saving launch path: loading settings: creating settings: serializing settings file /Users/swamishirdhankar/Library/Group Containers/ open /Users/swamishirdhankar/Library/Group Containers/ permission denied’

I’ve tried everything but not getting anywhere. I had docker installed previously as well but I had to uninstall it for some fundamental reasons but when tried reinstalling I’m receiving error posted above

Thanks much in advance

Hello maxim healthcare staffing@swami808 ,

The error you’re encountering indicates a permissions issue with the Docker Desktop installation on your Mac.
Docker Desktop requires certain permissions to perform privileged operations. Make sure Docker has the permissions to install symlinks in /usr/local/bin, bind privileged ports, and modify /etc/hosts.

The error message suggests that Docker does not have permission to write to the settings.json file.

On some systems, adding your user to the Docker group can resolve permission issues.

Sometimes, simply restarting the Docker service can resolve permission issues.

There might be macOS-specific permission issues, such as the permissions of the cli-plugins folder.

If these steps do not resolve the issue, you may want to consult the Docker forums or the Docker documentation for further assistance.

Best Regards,
maxim healthcare staffing