Docker Community Forums

Share and learn in the Docker community.

Exec user proccess caused "no such file or directory"

I’m trying to run a container but I keep getting the same error:
standard_init_linux.go:211: exec user process caused "no such file or directory"

Here is my dockerfile. I’ve tried with ENTRYPOINT AND CMD (not both of them together). Same error.

FROM ubuntu

#Copy the host files to the container
RUN \
mkdir -p /home/sigep/sigepbanco && \
mkdir -p /usr/java/jre1.8.0_211

COPY sigepbanco/ /home/sigep/sigepbanco/
COPY jre1.8.0_211/ /usr/java/jre1.8.0_211

#Manual java installation
RUN \
cd /usr/java && \
mv jre1.8.0_211 /usr/lib && \
update-alternatives --install "/usr/bin/java" "java" "/usr/lib/jre1.8.0_211/bin/java" 1 && \
update-alternatives --set java /usr/lib/jre1.8.0_211/bin/java && \
chmod 777 /usr/bin/java


ENTRYPOINT ["/home/sigep/sigepbanco/iniciarBanco.sh"]
#CMD ["/home/sigep/sigepbanco/iniciarBanco.sh"]

The application is pretty simple. It’s just a database which I’m gonna use in my client application.

Here is my iniciarBanco.sh. It starts the database listening on port 1527.

#!/bin/sh
java -jar derbyrun.jar server start -p 1527 -h 0.0.0.0

I’ve tried running docker run -it container with default /bin/bash endpoint and running the script mannualy. It worked. When I try to use it as my ENTRYPOINT I get this error.
I’m new to Docker, searched a lot of forums, but no solution yet. I’m using Docker CE for Linux.

From what i see, you missed to make the bash script executable.

Sorry, I forgot to mention. The permission is already set on the host file, so that when I copy it to the container it’s already executable.
Here it goes.
-rwxr-xr-x. 1 root root 94 Jul 10 16:45 iniciarBanco.sh