Docker Community Forums

Share and learn in the Docker community.

Fail to resolve docker.local

dns

(Tjamet) #1

Expected behavior

Given a container started with docker run -d -p 80:80 kitematic/hello-world-nginx
when I call curl docker.local I expect to get

Voilà! Your nginx container is running!

To edit files, double click the website_files folder in Kitematic and edit the index.html file.

Actual behavior

I get
curl docker.local
curl: (6) Could not resolve host: docker.local

Information

OS X: version 10.11.4 (build: 15E65)
Docker.app: version v1.11.1-beta11
Running diagnostic tests:
[OK] docker-cli
[OK] Moby booted
[OK] driver.amd64-linux
[OK] vmnetd
[OK] osxfs
[OK] db
[OK] slirp
[OK] menubar
[OK] environment
[OK] Docker
[OK] VT-x
Docker logs are being collected into /tmp/20160512-003148.tar.gz
Most specific failure is: No error was detected
Your unique id is: 2196A655-03A1-4E6C-B579-F5914F4F5C6C

My mac has a tunnelblick configured to change DNS settings
I also have a file in /etc/resolver/dockermachine.conf:
nameserver 192.168.99.100
domain .

Steps to reproduce the behavior

Computer freshly rebooted, a factory reset of docker for mac has been performed

I ran docker run --rm -p 80:80 kitematic/hello-world-nginx

and tried to curl docker.local and access docker.local in a web browser that still ends up with a DNS not found error.

There must be some misconfiguration somewhere on my system but do not manage to tackle it.

Thanks for your help


(Rohinton Kazak) #2

Please check out https://beta.docker.com/docs/mac/release-notes/

That has been deprecated.


(Tjamet) #3

my bad, sorry for inconvenience.
Thanks for your reply


(Dave Tucker) #4