Docker Community Forums

Share and learn in the Docker community.

Failed to pull golang:1.10-alpine

build

(Northtyphoon) #1

It seems Docker Hub is unstable now. Docker build ran into random failures when pulling golang:1.10-alpine image.

Logs:

Step 1/14 : FROM golang:1.10-alpine
1.10-alpine: Pulling from library/golang
error parsing HTTP 404 response body: invalid character ‘p’ after top-level value: “404 page not found\n”

Step 1/14 : FROM golang:1.10-alpine
unauthorized: authentication required


(Bluehotdog) #2

We see exactly the same errors on several different images


(Co0p) #3

I had a successful docker build using: golang:1.11.2-alpine . Before I was also running into the “invalid character” problem. Maybe it helps.


(Northtyphoon) #4

Tried to switch to golang:1.11.2-alpine. Started to see a new error.

Step 1/14 : FROM golang:1.11.2-alpine
1.11.2-alpine: Pulling from library/golang
4fe2ade4980c: Already exists
2e793f0ebe8a: Already exists
77995fba1918: Already exists
cacfaec3bb6b: Pulling fs layer
885a921d7cd2: Pulling fs layer
885a921d7cd2: Download complete
error pulling image configuration: unknown blob


(Northtyphoon) #5

It looks Docker Hub is investigating the high error rate.

https://status.docker.com/pages/533c6539221ae15e3f000031


(Rubendario) #6

I ran that line in a Dockerfile on my machine and I had no problem. The error must be on another line, check again.