Docker Community Forums

Share and learn in the Docker community.

Failed to start docker.service: Unit docker.socket not found after kernel update on lubuntu


(Docuser200) #1

I am facing this weird problem after getting lubuntu bionic upgrade which i believe updated Kernel. Docker installation was working perfectly fine until then and i was using it.
However now i am unable to use docker. Getting below message.
systemctl restart docker
Failed to restart docker.service: Unit docker.socket not found.

I did uninstall and install of docker ce again and still the same issue -
Any quick help will be appreciated -

some additional info :

sudo apt-cache showpkg docker-ce
Package: docker-ce
Versions:
5:18.09.0~3-0~ubuntu-bionic (/var/lib/apt/lists/download.docker.com_linux_ubuntu_dists_bionic_stable_binary-amd64_Packages) (/var/lib/dpkg/status)
Description Language:
File: /var/lib/apt/lists/download.docker.com_linux_ubuntu_dists_bionic_stable_binary-amd64_Packages
MD5: c44506b988c89e9690d4dddd3c768d77

18.06.1~ce~3-0~ubuntu (/var/lib/apt/lists/download.docker.com_linux_ubuntu_dists_bionic_stable_binary-amd64_Packages)
Description Language:
File: /var/lib/apt/lists/download.docker.com_linux_ubuntu_dists_bionic_stable_binary-amd64_Packages
MD5: b5239655e360ef67b74ba55fd74d7bf1
Description Language:
File: /var/lib/apt/lists/download.docker.com_linux_ubuntu_dists_bionic_stable_binary-amd64_Packages
MD5: b5239655e360ef67b74ba55fd74d7bf1

18.06.0~ce~3-0~ubuntu (/var/lib/apt/lists/download.docker.com_linux_ubuntu_dists_bionic_stable_binary-amd64_Packages)
Description Language:
File: /var/lib/apt/lists/download.docker.com_linux_ubuntu_dists_bionic_stable_binary-amd64_Packages
MD5: b5239655e360ef67b74ba55fd74d7bf1
Description Language:
File: /var/lib/apt/lists/download.docker.com_linux_ubuntu_dists_bionic_stable_binary-amd64_Packages
MD5: b5239655e360ef67b74ba55fd74d7bf1

18.03.1~ce~3-0~ubuntu (/var/lib/apt/lists/download.docker.com_linux_ubuntu_dists_bionic_stable_binary-amd64_Packages)
Description Language:
File: /var/lib/apt/lists/download.docker.com_linux_ubuntu_dists_bionic_stable_binary-amd64_Packages
MD5: 081115dab45344eb40852d38ab20e419

Reverse Depends:
docker-ce-cli,docker-ce 5:18.09
docker-ce-cli,docker-ce 5:18.09
cockpit-docker,docker-ce 1.3.0
cockpit-docker,docker-ce 1.3.0
whalebuilder,docker-ce
Dependencies:
5:18.09.0~3-0~ubuntu-bionic - docker-ce-cli (0 (null)) containerd.io (0 (null)) iptables (0 (null)) libseccomp2 (2 2.3.0) libc6 (2 2.17) libsystemd0 (0 (null)) docker (3 1.5~) docker:i386 (3 1.5~) docker-engine (0 (null)) docker-engine-cs (0 (null)) docker.io (0 (null)) docker.io:i386 (0 (null)) lxc-docker (0 (null)) lxc-docker-virtual-package (0 (null)) aufs-tools (0 (null)) ca-certificates (0 (null)) cgroupfs-mount (16 (null)) cgroup-lite (0 (null)) git (0 (null)) pigz (0 (null)) xz-utils (0 (null)) libltdl7 (0 (null)) apparmor (0 (null)) docker-engine (0 (null))
18.06.1~ce~3-0~ubuntu - iptables (0 (null)) libc6 (2 2.17) libdevmapper1.02.1 (2 2:1.02.97) libltdl7 (2 2.4.6) libseccomp2 (2 2.3.0) libsystemd0 (0 (null)) docker (3 1.5~) docker:i386 (3 1.5~) docker-ee (0 (null)) docker-engine (0 (null)) docker-engine-cs (0 (null)) docker.io (0 (null)) docker.io:i386 (0 (null)) lxc-docker (0 (null)) lxc-docker-virtual-package (0 (null)) aufs-tools (0 (null)) ca-certificates (0 (null)) cgroupfs-mount (16 (null)) cgroup-lite (0 (null)) git (0 (null)) pigz (0 (null)) xz-utils (0 (null)) apparmor (0 (null)) docker-engine (0 (null))
18.06.0~ce~3-0~ubuntu - iptables (0 (null)) libc6 (2 2.17) libdevmapper1.02.1 (2 2:1.02.97) libltdl7 (2 2.4.6) libseccomp2 (2 2.3.0) libsystemd0 (0 (null)) docker (3 1.5~) docker:i386 (3 1.5~) docker-ee (0 (null)) docker-engine (0 (null)) docker-engine-cs (0 (null)) docker.io (0 (null)) docker.io:i386 (0 (null)) lxc-docker (0 (null)) lxc-docker-virtual-package (0 (null)) aufs-tools (0 (null)) ca-certificates (0 (null)) cgroupfs-mount (16 (null)) cgroup-lite (0 (null)) git (0 (null)) pigz (0 (null)) xz-utils (0 (null)) apparmor (0 (null)) docker-engine (0 (null))
18.03.1~ce~3-0~ubuntu - iptables (0 (null)) libc6 (2 2.17) libdevmapper1.02.1 (2 2:1.02.97) libltdl7 (2 2.4.6) libseccomp2 (2 2.3.0) libsystemd0 (0 (null)) docker (3 1.5~) docker:i386 (3 1.5~) docker-ee (0 (null)) docker-engine (0 (null)) docker-engine-cs (0 (null)) docker.io (0 (null)) docker.io:i386 (0 (null)) lxc-docker (0 (null)) lxc-docker-virtual-package (0 (null)) aufs-tools (0 (null)) ca-certificates (0 (null)) cgroupfs-mount (16 (null)) cgroup-lite (0 (null)) git (0 (null)) pigz (0 (null)) xz-utils (0 (null)) apparmor (0 (null)) docker-engine (0 (null))
Provides:
5:18.09.0~3-0~ubuntu-bionic -
18.06.1~ce~3-0~ubuntu -
18.06.0~ce~3-0~ubuntu -
18.03.1~ce~3-0~ubuntu -
Reverse Provides:


(Vierer) #2

The docker 18.09 update is out for only a few days. So I asume, your update also updated docker.

See here if you made changes to the systemd startup files: Failed to load listeners: no sockets found via socket activation: make sure the service was started by systemd


(Docuser200) #3

@vierer Thanks for your response. You were correct. Looks like my system caused docker issue. I uninstalled docker 18.09 and reinstalled 18.03 which worked fine. Does that mean 18.09 version is not stable ?? May be bug need to be filed ?


(Lunarxlark) #4

This problem also happend for me. My Ubuntu missed file ‘/usr/lib/systemd/system/docker.socket’.
Then create file ‘docker.socket’ hence below link. I succeed to start docker.service.