Docker Community Forums

Share and learn in the Docker community.

Failing (exit status 66) to download Golang packages in a windows based Docker container

docker

(Sisimogangg) #1

Expected behavior

Should be able to download Golang in a windowsservercore container just as we can in Linux containers. i.e.

go get -d github.com/gorilla/mux

must download and install package mux with no issues.

Actual behavior

I have downloaded several Windows Golang images from docker hub and I have tried installing (go get) packages from inside the container. This fails with the following error (happens for all the various images I have tried).

Information

I have even tried using a pure windowsservercore image, where I installed Golang and Git before running the go get command.

I’m not entirely sure what the issue could be but I believe status 66 has something to do with data race ? how do I fix this ?

Steps to reproduce the behavior

Step 1:

Docker pull golang:1.11.1-windowsservercore-1709  

Step 2:

Docker run -it --rm golang:1.11.1-windowsservercore-1709 powershell

Step 3:

PS C:\gopath> go get -d github.com/gorilla/mux

(Dockerdurban) #2

I ran : docker run --pull -it --rm golang:1.11.1-windowsservercore-1709
Then when in the container i checked that the go environment variable was there
and checked that git was installed.
Finally ran the go get github.com/gorilla/mux and all was cloned fine.


(Sisimogangg) #3

Hey @dockerdurban

This fails on my machine. Not sure why though. Below is a screenshot of a failed docker build.


(Sisimogangg) #4

@dockerdurban I am currently trying this on another laptop.