Docker Community Forums

Share and learn in the Docker community.

Failure to chown a directory on the host


(Ekkis) #1

the seegno/bitcoin image attempts to chown a directory that I’ve mounted on my local filesystem and fails. this seems to work for others but fails for me. I’m running RC3-beta18 build 9969

Expected behavior

container should run

Actual behavior

container fails with permissions problem:

chown: changing ownership of ‘/data’: Operation not permitted

Information

  • the output of:
    • Moby Menu > Diagnose & Feedback on OSX

Docker for Mac: version: mac-v1.12.0-beta18
OS X: version 10.11.5 (build: 15F34)
logs: /tmp/20160705-132452.tar.gz
[OK] docker-cli
[OK] app
[OK] menubar
[OK] virtualization
[OK] system
[OK] osxfs
[OK] db
[OK] slirp
[OK] moby-console
[OK] logs
[OK] vmnetd
[OK] env
[OK] moby
[OK] driver.amd64-linux

  • a reproducible case if this is a bug, Dockerfiles FTW

  • host distribution and version ( OSX 10.10.x, OSX 10.11.x, Windows, etc )

OSX 10.11.5

Steps to reproduce the behavior

  1. cd ~/test
  2. mkdir bitcoind
  3. docker run --rm -it --name bitcoind -p 8332 -e BITCOIN_DATA=/data -v ${PWD}/bitcoind:/data seegno/bitcoind:latest -server -printtoconsole

(Ekkis) #2

SOLVED: I killed all containers on my system, removed all volumes, all images and attempted the command again. it worked so I guess it was just a case of bad juju from the times I was running the container in boot2docker