Gcc-12-base:amd64.list error (related to moving Docker data dir?)

///

OS: Linux ubuntu-desktop 5.15.0-52-generic (Ubuntu 22.04.1)
Docker-version: 20.10.20, build 9fdeb9c
My user added to the “docker” group? Yes
Content of “/etc/docker/daemon.json”:

{
   "data-root": "/media/my-user/Intenso 1TB USB 3.0/docker-data-root",
   "storage-driver": "vfs"
}

Why am I using “vfs” as the storage driver? “Intenso 1TB USB 3.0” is a NTFS-formatted external HDD

///

Hello,

Trying to install a certain image;
https://hub.docker.com/r/overv/openstreetmap-tile-server/

I’ve earlier specified / moved the docker data-dir to an external HDD (formatted in NTFS) because a lack of storage space on my main drive (the container grew beyond… 100GB before I ran out of diskspace on another computer).

Trying to run this command;

docker run \
    -v "/media/my-user/Intenso 1TB USB 3.0/OpenStreetMap Maps/europe-latest.osm.pbf":/data/region.osm.pbf \
    -v osm-data:/data/database/ \
    overv/openstreetmap-tile-server \
    import

This is the output;

Unable to find image 'overv/openstreetmap-tile-server:latest' locally
latest: Pulling from overv/openstreetmap-tile-server
2b55860d4c66: Extracting [==================================================>]  30.43MB/30.43MB
b3ebc3d5b46f: Download complete 
17bcfe5d9ac6: Download complete 
b0757acbd90d: Download complete 
e7668da01188: Download complete 
cf44108a6f2e: Download complete 
a7fe7fcf597d: Download complete 
44d2ac45fdce: Download complete 
b8e3462ab220: Download complete 
f81545cb353c: Download complete 
db643d082c5b: Download complete 
43f665c196ea: Download complete 
2733645c9d98: Download complete 
873ad971dfa5: Download complete 
65c9905ac4c8: Download complete 
caa925c4f853: Download complete 
f33a2add998d: Download complete 
db39fdc81f85: Download complete 
a1fbf5ef14ea: Download complete 
b6976975257f: Download complete 
9731aefddecb: Download complete 
84e0dcfd0341: Download complete 
5ced7d71c0cf: Download complete 
docker: failed to register layer: ApplyLayer exit status 1 stdout:  stderr: open /var/lib/dpkg/info/gcc-12-base:amd64.list: invalid argument.
See 'docker run --help'.

Ok so this worked on my other machine where I didn’t modify / created “/etc/docker/daemon.json” and moved Docker’s data-dir…

I thought this might have been related that my Ubuntu-installation was missing “gcc-12” so I installed it using “Brew” and now have;

gcc --version
gcc (Ubuntu 11.3.0-1ubuntu1~22.04) 11.3.0

and

gcc-12 --version
gcc-12 (Homebrew GCC 12.2.0) 12.2.0

however gcc-12-base seems to already be installed natively in Ubuntu

sudo apt-get install gcc-12-base
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
gcc-12-base is already the newest version (12.1.0-2ubuntu1~22.04).

the file it mentions - /var/lib/dpkg/info/gcc-12-base:amd64.list - exists;

find /var/lib/dpkg/info -iname gcc-12-base:amd64.list
/var/lib/dpkg/info/gcc-12-base:amd64.list

Would appreciate any suggestions / help - TheSwede86

It is not about GCC. The error message says:

stderr: open <filepath>: invalid argument

It wants to open that file and then the error happens. The fact that it happened when it wanted to open a file with “gcc” in it’s name doesn’t matter.

I don’t know why it happens, but it could be because of vfs which is not recommended for production, but I have never used it for testing either, so I don’t know if vfs can cause something liek this, but I guess it shouldn’t.

Maybe it just can’t read the file because your attached disk disconnected temporarily or just did not respond. Or maybe there is a filesystem error on your external drive.

Can you run an other container?