Getting error when running container: env: can't execute 'node': Text file busy

I am getting the following error when attempting to build a container using node:alpine3.17. env: can’t execute ‘node’: Text file busy. It’s a simple frontend container. I am reasonably sure it used to work but now well here I am. I have tried using bullseye instead of alpine, same issue. It works on windows using wsl2 integration but fails on macos(apple silicon) and pop!_os. I tried to isolate the issue since I’m building the project with docker compose and built a standalone container using the following Dockerfile:

FROM node:20-alpine3.17


COPY . .

RUN yarn install

CMD ["yarn", "start"]

I’m at a bit of a loss. Sorry in advance if it’s not in the right place or not precise enough.

mod update: fixed syntax of “Preformated text”/colde block → the three backticks need to be in separate lines.

I encountered the same issue with node:20-alpine. I fixed it by downgrading the version to node:18-alpine

1 Like

Bro you’re saving my life. Works fine after downgrading. Thank you so much!

Also works with node:20.2.0-alpine3.18, seems it stopped working with 20.3.0

1 Like

We saw the same with node:20.3-slim and reverted back to node:20.2-slim

Wonder where an appropriate changelog could be found.

Edit: found Node 20 images give error `/usr/bin/env: 'node': Text file busy` · Issue #1912 · nodejs/docker-node · GitHub

1 Like