Docker Community Forums

Share and learn in the Docker community.

Getting Started tutorial Part 3 - curl fails to connect

swarm
docker

(Mcody1) #1

I’m attempting to perform the Getting Started tutorial Part 3 - Services. All appears to work as expected until I try to use curl to connect to port 80. Essentially curl just hangs with no response. Pointing a web browser (Firefox) at http://localhost/ also fails to get a response. Another Docker user has encountered the same problem, as described in the stackoverflow.com posting below.
https://stackoverflow.com/questions/43750370/following-the-get-started-stack-server-stuck-loading-page-endlessly#
The docker images works fine in Part 1 of the tutorial. Only when used in conjunction with the docker-compose.yml file and docker swarm does this problem occur. As suggested in the stackoverflow posting, I tried
docker exec ContainerID /bin/sh
but that action hung as well. Help would be appreciated to get past this problem as I strive to learn. I’m running Docker version 17.03.1-ce, build c6d412e on Fedora 25.

Thanks,

Mac


Stuck on Getting Started tutorial part 3
(Mcody1) #2

I’ve continued to work this issue and found something that I find a bit concerning. I first made sure that all of the prerequisites for Getting Started tutorial Part 3 were met. I then tried running docker swarm init to study the resulting output.

$ docker swarm init
Swarm initialized: current node (nsng7da5c2glu5zfjb4iwwxz7) is now a manager.

To add a worker to this swarm, run the following command:

docker swarm join
–token SWMTKN-1-0b1m1gujzrl6jjdfpkrosefhcuemxb27cktyc782b0hu8bct0t-9oxn5pd7b29p9n7l4bhn2segg
162.36.205.58:2377

To add a manager to this swarm, run ‘docker swarm join-token manager’ and follow the instructions.
$

I noticed that nothing was mentioned about docker deploy is a possible operation. I decided to see what help was available on docker deploy. To my surprise, none was available. Executing docker --help did not even list deploy as an option. Executing docker deploy --help yielded the following:

$ docker deploy --help
only supported with experimental daemon
$

So what is the experimental daemon? I’m sort of surprised that a Getting Started tutorial is based on ‘experimental’ software and not the current stable software. I’d certainly appreciate an explanation and a pointer to a usable tutorial that only uses features in the stable version of Docker.

Thanks,

Mac


(Rathael) #3

I was doing the same tutorial and I had the same problem with curl, so I used this:
curl -4 http://localhost
but I couldn’t connect with the browser.


(Pacaj2am) #4

Hi, experiencinig the same problem, Ubuntu 17.04.

curl -4 not helping… :frowning:


(S1mpl3) #5

I skipped this step. Took too much time.