Docker Community Forums

Share and learn in the Docker community.

Having access denied when i try to push to repo

denied: requested access to the resource is denied

That is unfortunate… but we can’t help if you don’t help us with further details. You don’t have permission to access “seomething”. This is all I can say wihout knowing what you are trying to do. Maybe one more thing. Don’t forget to use docker login to access a private repo.

Ok I want to push to my repo which is public and I login through terminal.
I have tag my image
Sudo docker tag abisco-website:latest abisco/website:1
When I try to push
sudo docker push abisco/website:1
the last line returns as access denied:requested access to the resource is denied denied

I suppose you are on Linux, right? Did you log in from the same terminal where you run docker push?

Yes sir It was the same terminal

I added you as collaborator to one of my test image. Try to pull it:

docker pull rimelek/test2

Just to see if you logged in successfully.

Update:

OK. I can’t even list my own repositories now. I can pull them, but can’t find them on the website. This must be a temporary issue with Docker Hub.

sudo docker pull rimelek/test2
Using default tag: latest
Error response from daemon: pull access denied for rimelek/test2, repository does not exist or may require ‘docker login’: denied: requested access to the resource is denied

Then either the current issue affects some people’s authorization or your login was not successful

oh ok thank you very much i’ll keep trying and revert back when i can, or if you find a way before i do pls let me know

actually it was successful
Authenticating with existing credentials…
WARNING! Your password will be stored unencrypted in /root/.docker/config.json.
Configure a credential helper to remove this warning. See

Login Succeeded

I can see my repositories again. I hope your issue will also be solved soon.

i can now push my brother helped but i can’t pull ur image

That’s OK. I have never tried to add a collaborator. It is possible I missed something.

you add using the user docker id

this wat I did i build den login
then tag before i pushed push

this is my docker id abiolaabisco so add as colaborator den i can pull or push

That’s it. I addad abisco which was in the name of your docker image which is another user. Or is that yours too? Because if that is, you need to loin with the right user.

na mine is abiolaabisco