Help to debug, PHP-FPM killed with no errors after few minutes

I’m trying to setup nextcloud + nginx on docker, but the container just stops few seconds later, I noticed that the php-fpm (the entrypoint) just exits without error. So I tried to run a clean php-fpm image, just be sure this isn’t a nextcloud error, and this is what happens:

# docker run -it php:fpm
# [22-Sep-2017 10:45:30] NOTICE: fpm is running, pid 1
# [22-Sep-2017 10:45:30] NOTICE: ready to handle connections

After that I got throw back to the shell without any error log and a exit code 137,if I run a compose with restart: always, the container just restarts after a few seconds over and over again, also tried to run a shell and run php-fpm, same thing, still no error nor a log to check. This is the frustrating bit, not the error in itself but I don’t know how to debug and fix it.
The nginx container works without problems, php:apache runs perfectly, so far any other container I tried worked except this one.

Additional Information:

Device: QNAP NAS
OS: Linux 4.2.8 #1 SMP Fri Sep 1 01:08:22 CST 2017 x86_64 GNU/Linux
Docker version: 1.11.2