How can i install docker on i386?

I still have a computer with an i7-2600 64bit CPU, how do I get Docker installed on it? apt update always says there are no packages for i386!

This would only make sense, if you actually installed the i386 version of the operating system, that runs a i386 kernel. Please share the output of uname -a.

Your CPU architecture is x86_64, so installing one of the supported operating systems for the cpu architecture is a precondition to get Docker installed: https://docs.docker.com/engine/install/#supported-platforms